Blob Blame History Raw
%define pybasever 1.5
%define pynextver 1.6

Summary: An interface to MySQL
Name: MySQL-python
Version: 0.9.1
Release: 1
Source0: http://www.mysql.com/Downloads/Contrib/MySQL-python-%{version}.tar.gz
Patch0: MySQL-python-0.9.0-pytuple.patch
License: GPL
Group: Development/Libraries
BuildRoot: %{_tmppath}/%{name}-buildroot
URL: http://www.mysql.com/downloads/api-python.html
Requires: python mx mysql
Requires: python >= %{pybasever}, python < %{pynextver}
BuildRequires: python-devel >= %{pybasever}, python-devel < %{pynextver}
BuildRequires: mysql-devel python Distutils gcc zlib-devel

%description
Python interface to MySQL-3.22 and 3.23

MySQLdb is an interface to the popular MySQL database server for Python.
The design goals are:

-     Compliance with Python database API version 2.0 
-     Thread-safety 
-     Thread-friendliness (threads will not block each other) 
-     Compatibility with MySQL 3.22 and 3.23

This module should be mostly compatible with an older interface
written by Joe Skinner and others. However, the older version is
a) not thread-friendly, b) written for MySQL 3.21, c) apparently
not actively maintained. No code from that version is used in
MySQLdb. MySQLdb is distributed free of charge under a license
derived from the Python license.

%prep
%setup -q
#patch0 -p1

%build
rm -f doc/*~
CFLAGS="$RPM_OPT_FLAGS" python setup.py build

%install
python setup.py install --root=$RPM_BUILD_ROOT --record=INSTALLED_FILES

%clean
rm -rf $RPM_BUILD_ROOT

%files -f INSTALLED_FILES
%defattr(-,root,root)
%doc README doc/*
%dir /usr/lib/python%{pybasever}/site-packages/MySQLdb

%changelog
* Wed Mar 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.1-1
- 0.9.1

* Tue Feb 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.9.0-6
- Rebuild

* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 0.9.0-5
- Change python conflicts to requires
- Use pybasever/pynextver macros.

* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
- automated rebuild

* Fri Sep 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.9.0-3
- Build for Python 2.2

* Mon Jul 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
- Add zlib-devel to buildrequires (#49788)

* Tue Jun 19 2001 Trond Eivind Glomsrød <teg@redhat.com>
- Initial build