Blob Blame History Raw
# Minimum audacious/audacious-plugins version in inter-package
# dependencies.
# We need 2.2 as 2.1 is insufficient.
%define aud_ver 2.2

Name: audacious-plugins
Version: 2.2
Release: 5%{?dist}
Summary: Plugins for the Audacious media player
Group: Applications/Multimedia
URL: http://audacious-media-player.org/

# LGPLv2+: adplug, bio2jack, rocklight
# MIT: crystalizer, dockalbumart
# BSD: lastfm
License: GPLv2 and GPLv2+ and LGPLv2+ and MIT and BSD

# Modified source tarball to remove problematic files.
# Removed: aac madplug
# Disabled via options where possible, see %%build.
Source0: audacious-plugins-fedora-%{version}.tar.bz2
#Source0: http://distfiles.atheme.org/audacious-plugins-%{version}.tgz
Source1: audacious-sid.desktop

Patch0: audacious-plugins-2.0.1-xmms-skindir.patch
# obsolete with version upgrade: declaration conflict for jack_free
Patch1: audacious-plugins-2.2-jack.patch
#
Patch2: audacious-plugins-2.2-neon-request.patch
# submitted upstream
Patch3: audacious-plugins-2.2-cfg_db_close.patch
# submitted upstream
Patch4: audacious-plugins-2.2-bluetooth.patch

BuildRequires: audacious-devel >= %{aud_ver}
BuildRequires: jack-audio-connection-kit-devel libsamplerate-devel
BuildRequires: alsa-lib-devel
BuildRequires: pulseaudio-libs-devel
BuildRequires: esound-devel
BuildRequires: libsndfile-devel
BuildRequires: taglib-devel
BuildRequires: wavpack-devel
BuildRequires: libsidplay-devel
BuildRequires: libogg-devel libvorbis-devel
BuildRequires: flac-devel
BuildRequires: libmodplug-devel
BuildRequires: fluidsynth-devel
BuildRequires: libshout-devel
BuildRequires: curl-devel
BuildRequires: libbinio-devel
BuildRequires: libcdio-devel
BuildRequires: libcue-devel
BuildRequires: SDL-devel
BuildRequires: lirc-devel
BuildRequires: bluez-libs-devel
BuildRequires: libXcomposite-devel
BuildRequires: libcddb-devel
BuildRequires: libmtp-devel
BuildRequires: libxml2-devel
BuildRequires: gettext
BuildRequires: desktop-file-utils

# experimental, disabled by default
BuildRequires: neon-devel

Requires: audacious >= %{aud_ver}

# last in 1.5.1
Obsoletes: audacious-plugins-arts

# last tagged f8-final
Obsoletes: audacious-plugins-pulseaudio <= 1.3.5
Provides: audacious-plugins-pulseaudio = %{version}

# obsolete old subpackage -- no reason to split this off
Obsoletes: audacious-plugins-metronome < 2.2-2
Provides: audacious-plugins-metronome = %{version}-%{release}


%description
Audacious is a media player that currently uses a skinned user interface
(based on Winamp 2.x skins) as well as a separate GTK2 based front end.
Historically, it started as a fork of Beep Media Player (BMP), which
itself forked from XMMS.

This package provides essential plugins for audio input, audio output and
visualization.


%package jack
Summary: Audacious output plugin for Jack Audio Connection Kit
Group: Applications/Multimedia
# ancient
#Obsoletes: audacious-jack <= 1.1.2
Requires: audacious >= %{aud_ver}, audacious-plugins >= %{aud_ver}

%description jack
This package provides an Audacious output plugin that uses the
Jack Audio Connection Kit (JACK) sound service.


%package esd
Summary: Audacious output plugin for EsounD service
Group: Applications/Multimedia
# ancient
#Obsoletes: audacious-esd <= 1.1.2
Requires: audacious >= %{aud_ver}, audacious-plugins >= %{aud_ver}

%description esd
This package provides an Audacious output plugin that uses the
EsounD service.


%package amidi
Summary: Audacious input plugin for MIDI
Group: Applications/Multimedia
Requires: audacious >= %{aud_ver}, audacious-plugins >= %{aud_ver}

%description amidi
This package provides AMIDI-Plug, a modular MIDI music player, as an
input plugin for Audacious.


%package sid
Summary: Audacious input plugin for SID music files
Group: Applications/Multimedia
Requires: audacious >= %{aud_ver}, audacious-plugins >= %{aud_ver}
Requires(post): desktop-file-utils
Requires(postun): desktop-file-utils

%description sid
This package provides an Audacious input plugin for SID music files.

This build of the plugin uses libsidplay 1. 3rd party package
providers may build it with libsidplay 2.


%package wavpack
Summary: Audacious input plugin for WavPack compressed files
Group: Applications/Multimedia
Requires: audacious >= %{aud_ver}, audacious-plugins >= %{aud_ver}

%description wavpack
This package provides an Audacious input plugin that reads WavPack
compressed files.


%package vortex
Summary: Audacious input plugin for Vortex format files
Group: Applications/Multimedia
Requires: audacious >= %{aud_ver}, audacious-plugins >= %{aud_ver}

%description vortex
This package provides an Audacious input plugin that reads files
in Vortex (.vtx) format.



%prep
%setup -q -n audacious-plugins-fedora-%{version}
%patch0 -p1 -b .xmms-skindir
%patch1 -p1 -b .jack
%patch2 -p1 -b .neon-request
%patch3 -p1 -b .cfg_db_close
%patch4 -p1 -b .bluetooth

sed -i '\,^.SILENT:,d' buildsys.mk.in

%build
# --disable-esd
# --enable-neon : experimental, disabled by default
%configure  \
    --enable-chardet  \
    --enable-amidiplug  \
    --enable-neon  \
    \
    --disable-aac  \
    --disable-ffaudio  \
    --disable-mp3  \
    --disable-mms  \
    --disable-libmadtest  \
    \
    --disable-oss  \
    --disable-projectm  \
    --disable-sse2  \
    --disable-rpath  \
    --disable-dependency-tracking
make %{?_smp_mflags}


%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
%find_lang %{name}
# audacious-sid.desktop
desktop-file-install --vendor "" \
    --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
    %{SOURCE1}


%clean
rm -rf $RPM_BUILD_ROOT


%post sid
update-desktop-database &> /dev/null || :

%postun sid
update-desktop-database &> /dev/null || :


%files -f %{name}.lang
%defattr(-,root,root,-)
%doc AUTHORS COPYING
%{_libdir}/audacious/Input/
%{_libdir}/audacious/Output/
%{_libdir}/audacious/Container/
%{_libdir}/audacious/Effect/
%{_libdir}/audacious/General/
%{_libdir}/audacious/Visualization/
%{_libdir}/audacious/Transport/
%exclude %{_libdir}/audacious/Input/amidi-plug.so
%exclude %{_libdir}/audacious/Input/amidi-plug/
%exclude %{_libdir}/audacious/Input/wavpack.so
%exclude %{_libdir}/audacious/Input/sid.so
%exclude %{_libdir}/audacious/Input/vtx.so
%exclude %{_libdir}/audacious/Output/jackout.so
%exclude %{_libdir}/audacious/Output/ESD.so
%{_datadir}/audacious/

%files jack
%defattr(-,root,root,-)
%{_libdir}/audacious/Output/jackout.so

%files esd
%defattr(-,root,root,-)
%{_libdir}/audacious/Output/ESD.so

%files amidi
%defattr(-,root,root,-)
%{_libdir}/audacious/Input/amidi-plug.so
%{_libdir}/audacious/Input/amidi-plug/

%files sid
%defattr(-,root,root,-)
%{_libdir}/audacious/Input/sid.so
%{_datadir}/applications/audacious-sid.desktop

%files wavpack
%defattr(-,root,root,-)
%{_libdir}/audacious/Input/wavpack.so

%files vortex
%defattr(-,root,root,-)
%{_libdir}/audacious/Input/vtx.so


%changelog
* Fri Dec 25 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-5
- Remove BR libtimidity-devel as that plugin is no longer available.

* Fri Dec 25 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-4
- Let bluetooth plugin access "alsa-gapless" config values not "alsa"
  as it will be called in post-2.2.

* Sat Dec 19 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-3
- Beat bluetooth plugin a bit.
- Fix missing aud_cfg_db_close calls.
- Avoid that neon's ne_request_destroy() is called with a NULL ptr.

* Wed Dec  2 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-2
- Move SID music plugin into audacious-plugins-sid package. Its 
  built with libsidplay 1 while 3rd party package providers may
  build it with libsidplay 2.
- Include metronome plugin in base plugins package. No reason to
  split this off into an optional subpackage.

* Wed Nov 25 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-1
- Upgrade to 2.2 (declared as the next "stable release" after 2.1).
- The ladspa plugin has been reworked since beta2.

* Tue Nov 24 2009 Michael Schwendt <mschwendt@fedoraproject.org>
- BR libcue-devel which is available now and is enabled by default
  post 2.2-beta2
- Drop --disable-tta switch as that plugin is gone.

* Fri Nov 13 2009 Michael Schwendt <mschwendt@fedoraproject.org>
- Remove BR libmpcdec-devel ("musepack" plugin is not available anymore
  after 2.1 as it got removed in favour of "ffaudio"/ffmpeg plugin).

* Tue Nov 10 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-0.4.beta2
- Upgrade to 2.2-beta2
- Add patch to use old/working ladspa plugin from 2.0.1 (#533641).

* Fri Oct 30 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-0.4.beta1
- Fix non-top-level filewriter plugin dialogs.

* Sun Oct 25 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-0.3.beta1
- Update pulse_audio patch with correct get_song_name().

* Sun Oct 25 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-0.2.beta1
- Patch modplug plugin to remove old cruft and fix playback.

* Thu Oct 22 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-0.1.beta1
- Upgrade to 2.2-beta1
- Port old pulse_audio plugin from Audacious 2.1
  and patch it to fix volume issues.

* Wed Oct 21 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.1-7
- Patch pulseaudio plugin to not suffer from precision loss when
  calculating the volume level to save.

* Wed Oct 21 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.1-6
- Rediff the underruns patch and set buffer_time_min.

* Mon Oct 19 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.1-5
- Patch pulseaudio plugin to not get confused by volume values passed
  in via callback.

* Sun Oct 18 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-0.1.alpha2
- Upgrade to 2.2-alpha2 (breaks ALSA output with alsa-plugins-pulseaudio!)

* Sun Sep 20 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.2-0.1.alpha1
- Upgrade to 2.2-alpha1 (primarly for alsa-gapless output plugin).
- Removes pulse_audio output plugin!
- Obsolete patches: timidity-cfg, keep-mixer-open

* Sun Sep 20 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.1-4
- Patch alsa-ng plugin with some buffer prefilling to fight underruns.
- Merge minor changes from 2.2-alpha1 alsa-ng plugin.

* Thu Jul 30 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.1-3
- Keep mixer open and not start at only %50 volume.

* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

* Tue Jul 14 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.1-1
- Upgrade to 2.1 final.

* Mon Jun 29 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.1-0.1.beta1
- Upgrade to 2.1beta1.
- Drop merged/obsolete patches.

* Sat Jun  6 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.1-0.3
- Make libtimidity not try to open non-existing files.
- Fix non-top-level configure dialogs.

* Sat Jun  6 2009 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.1-0.1
- Upgrade to 2.0.1.
- Fix sndfile plugin cleanup crash.
- Major spec overhaul, and drop old %%changelog entries.
- Obsolete -arts plugin.
- Multiple different licenses are used for the individual plugins.
- Move amidi-plug directory to amidi subpackage.
- Build with libsndfile plugin for advanced formats in WAV and
  patch it for pause and seek (also fixes #501007).

* Wed May 06 2009 Ralf Ertzinger <ralf@skytale.net> 1.5.1-5
- Fix possible crash on neon buffer underrun (BZ#496413)