Blob Blame Raw
From ea2e255eeefe691828fee8055e9ebed816109acc Mon Sep 17 00:00:00 2001
From: Lars Kellogg-Stedman <lars@redhat.com>
Date: Wed, 1 Jun 2016 12:37:40 -0400
Subject: [PATCH] growpart: fix use of partx for newer util-linux versions

prevent errors with recent versions (2.28) versions of partx (still
works with earlier versions as well).
---
 bin/growpart | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/bin/growpart b/bin/growpart
index 85c2d1f..fd97a10 100755
--- a/bin/growpart
+++ b/bin/growpart
@@ -498,7 +498,7 @@ pt_update() {
 	if ! $update; then
 		return 0
 	fi
-	partx --update "$part" "$dev"
+	partx --update --nr "$part" "$dev"
 }
 
 has_cmd() {
-- 
2.7.4