Blob Blame History Raw
Name:    csmith
Version: 2.1.0
Release: 7%{?dist}
Summary: Tool to generate random C programs for compiler testing

Group:   Development/Tools
# Most of the source code is under BSD while few header files are GPLv2+ and LGPLv2+
License: BSD and GPLv2+ and LGPLv2+
URL:     http://embed.cs.utah.edu/csmith/
Source0: http://embed.cs.utah.edu/csmith/%{name}-%{version}.tar.gz
Patch0:  csmith-2.1.0-fix-powerpc64-build.patch
Patch1:  csmith-2.1.0-remove-custom-headers.patch
Patch2:  csmith-2.1.0-secondary.patch

BuildRequires: m4

%description
Csmith is a tool that can generate random C programs that 
statically and dynamically conform to the C99 standard. It is 
useful for stress-testing compilers, static analyzers, and 
other tools that process C code

%package devel
Summary:        Header files and libraries for Csmith development
Group:          Development/Libraries
Requires:       %{name} = %{version}-%{release}
Requires:       pkgconfig

%description devel 
The %{name}-devel package contains the header files
and libraries for use with the Csmith package.

%prep
%setup -q
%patch0 -p1 -b .ppc64
%patch1 -p1 -b .fix
%patch2 -p1 -b .secondary

%build
%configure
make %{?_smp_mflags}

%install
rm -rf %{buildroot}
make install DESTDIR=%{buildroot}
find %{buildroot} -name *.a  -exec rm -f {} \;
find %{buildroot} -name *.la -exec rm -f {} \;
find %{buildroot} -name test_csmith.pl -exec rm -f {} \;
rm -f %{buildroot}%{_bindir}/compiler_test.in
rm -rf %{buildroot}%{_docdir}/%{name}

%clean
rm -rf %{buildroot}

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%files
%defattr(-,root,root,-)
%doc COPYING doc/probabilities.txt scripts/compiler_test.in
%{_bindir}/compiler_test.pl
%{_bindir}/csmith
%{_bindir}/launchn.pl
%{_libdir}/libcsmith.so.*

%files devel
%defattr(-,root,root,-)
%{_includedir}/%{name}-%{version}
%{_libdir}/libcsmith.so

%changelog
* Thu Dec 06 2012 Dan HorĂ¡k <dan[at]danny.cz> - 2.1.0-7
- fix build on all arches by adding fallback implementation for getting initial seed

* Mon Nov 19 2012 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 2.1.0-6
- Removed BuildRoot tag
- Add multiple license comment
- Remove /usr/share/doc/csmith directory

* Mon Oct 29 2012 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 2.1.0-5
- Update docdir

* Sat Jun 02 2012 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 2.1.0-4
- Use system header files.

* Thu Dec 01 2011 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 2.1.0-3
- Removed test_csmith.pl from the package.

* Sat Nov 26 2011 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 2.1.0-2
- Move compiler_test.in to doc.
- Apply patch to build for ppc64.
- Added licenses.

* Wed Nov 23 2011 Shakthi Kannan <shakthimaan [AT] fedoraproject dot org> 2.1.0-1 
- Initial build.