Blob Blame History Raw
%define fontname    dejavu
%define fontdir     %{_datadir}/fonts/%{fontname}/
%define fontconfdir %{_sysconfdir}/fonts/conf.d/

%define archivename %{name}-%{archiveversion}

#define alphatag .20080512svn2226
#define alphatag .rc1

#define archiveversion 2.24-20080512-2226
%define archiveversion %{version}

# Let the perl maintainer worry about Unicode.org data files
%define Blocks          %(eval "$(%{__perl} -V:privlibexp)"; echo $privlibexp)/unicore/Blocks.txt
%define UnicodeData     %(eval "$(%{__perl} -V:privlibexp)"; echo $privlibexp)/unicore/UnicodeData.txt

# Common description
%define common_desc \
The DejaVu font set is based on the “Bitstream Vera” fonts, release 1.10. Its\
purpose is to provide a wider range of characters, while maintaining the \
original style, using an open collaborative development process.

# Compat description
%define compat_desc \
This package only exists to help transition pre 2.26-3 DejaVu users to the new\
package split. It will be removed after one distribution release cycle, please\
do not reference it or depend on it in any way.\
\
It can be safely uninstalled. 


# Subpackage magic - should be generic enough for reuse in other packages
%define font_subpkg(n:f:) \
\
%post %{-n*} \
if [ -x %{_bindir}/fc-cache ]; then \
    %{_bindir}/fc-cache %{fontdir} || : \
fi \
\
\
%postun %{-n*} \
if [ $1 -eq 0 -a -x %{_bindir}/fc-cache ] ; then \
    %{_bindir}/fc-cache %{fontdir} || : \
fi\
\
\
%files %{-n*} \
%defattr(0644,root,root,0755) \
\
%{-f:%config(noreplace) %{fontconfdir}%{-f*}} \
\
%(echo %* | sed "s+ +\\n+g"| sed "s+^+%{fontdir}+g")

Name:    %{fontname}-fonts
Version: 2.26
Release: 6%{?alphatag}%{?dist}
Summary: DejaVu fonts

Group:   User Interface/X
License: Bitstream Vera and Public Domain
URL:     http://%{fontname}.sf.net/
Source0: %{?!alphatag:http://downloads.sourceforge.net/%{fontname}}%{?alphatag:%{fontname}.sourceforge.net/snapshots}/%{archivename}.tar.bz2
Patch0:  %{name}-2.26-fontconfig.patch

BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
# Older fontforge versions will not work due to sfd format changes
BuildRequires: fontforge >= 20080429
BuildRequires: perl(Font::TTF)
# Needed to compute unicode coverage
BuildRequires: %{Blocks} %{UnicodeData}
BuildArch: noarch

%description
%common_desc


%package common
Summary:  DejaVu fonts, common files (documentation…)
Group:    User Interface/X

Obsoletes: dejavu-fonts-doc < 2.26-6

%description common
%common_desc

This package consists of files used by other DejaVu packages.


%package compat
Summary: DejaVu fonts, compatibility
Group:   User Interface/X

Obsoletes: dejavu-fonts < 2.26-3
Obsoletes: dejavu-fonts-experimental < 2.26-3

Requires: %{name}-sans, %{name}-serif, %{name}-sans-mono

%description compat
%compat_desc


%package lgc-compat
Summary: DejaVu fonts, LGC compatibility
Group:   User Interface/X

Obsoletes: dejavu-lgc-fonts < 2.26-3

Requires: %{name}-lgc-sans, %{name}-lgc-serif, %{name}-lgc-sans-mono

%description lgc-compat
%compat_desc


%package sans
Summary:  DejaVu, variable-width sans-serif font faces
Group:    User Interface/X
Requires: %{name}-common = %{version}-%{release}

%description sans
%common_desc

This package consists of the DejaVu sans-serif variable-width font faces, in
their unabridged version.

%font_subpkg -n sans -f *-%{fontname}-sans.conf DejaVuSans.ttf DejaVuSans-*.ttf DejaVuSansCondensed*.ttf


%package serif
Summary:  DejaVu, variable-width serif font faces
Group:    User Interface/X
Requires: %{name}-common = %{version}-%{release}

%description serif
%common_desc

This package consists of the DejaVu serif variable-width font faces, in their
unabridged version.

%font_subpkg -n serif -f *-%{fontname}-serif.conf DejaVuSerif.ttf DejaVuSerif-*.ttf DejaVuSerifCondensed*.ttf


%package sans-mono
Summary:  DejaVu, monospace sans-serif font faces
Group:    User Interface/X
Requires: %{name}-common = %{version}-%{release}

%description sans-mono
%common_desc

This package consists of the DejaVu sans-serif monospace font faces, in their
unabridged version.

%font_subpkg -n sans-mono -f *-%{fontname}-sans-mono.conf DejaVuSansMono*.ttf


%package lgc-sans
Summary:  DejaVu, variable-width sans-serif font faces, Latin-Greek-Cyrillic subset
Group:    User Interface/X
Requires: %{name}-common = %{version}-%{release}

%description lgc-sans
%common_desc

This package consists of the DejaVu sans-serif variable-width font faces, with
unicode coverage restricted to Latin, Greek and Cyrillic.

%font_subpkg -n lgc-sans -f *-%{fontname}-lgc-sans.conf DejaVuLGCSans.ttf DejaVuLGCSans-*.ttf DejaVuLGCSansCondensed*.ttf


%package lgc-serif
Summary:  DejaVu, variable-width serif font faces, Latin-Greek-Cyrillic subset
Group:    User Interface/X
Requires: %{name}-common = %{version}-%{release}

%description lgc-serif
%common_desc

This package consists of the DejaVu serif variable-width font faces, with
unicode coverage restricted to Latin, Greek and Cyrillic.

%font_subpkg -n lgc-serif -f *-%{fontname}-lgc-serif.conf DejaVuLGCSerif.ttf DejaVuLGCSerif-*.ttf DejaVuLGCSerifCondensed*.ttf


%package lgc-sans-mono
Summary:  DejaVu, monospace sans-serif font faces, Latin-Greek-Cyrillic subset
Group:    User Interface/X
Requires: %{name}-common = %{version}-%{release}

%description lgc-sans-mono
%common_desc

This package consists of the DejaVu sans-serif monospace font faces, with
unicode coverage restricted to Latin, Greek and Cyrillic.

%font_subpkg -n lgc-sans-mono -f *-%{fontname}-lgc-sans-mono.conf DejaVuLGCSansMono*.ttf


%prep
%setup -q -n %{archivename}
%patch0 -p1


%build
make %{?_smp_mflags} VERSION=%{version} FC-LANG="" \
     BLOCKS=%{Blocks} UNICODEDATA=%{UnicodeData}

# Stop the desktop people from complaining this file is too big
bzip2 -9 build/status.txt


%check
make check


%install
rm -fr %{buildroot}

install -m 0755 -d %{buildroot}%{fontdir}
install -m 0644 -p build/*.ttf %{buildroot}%{fontdir}

install -m 0755 -d %{buildroot}%{fontconfdir}
install -m 0644 -p fontconfig/*conf %{buildroot}%{fontconfdir}


%clean
rm -fr %{buildroot}

%files common
%defattr(0644,root,root,0755)
%doc AUTHORS BUGS LICENSE NEWS README
%doc build/unicover.txt build/status.txt.bz2

%dir %{fontdir}/


%files compat
%files lgc-compat


%changelog
* Sun Nov 9 2008 Nicolas Mailhot <nicolas.mailhot at laposte.net>
- 2.26-6
⧎ Package split reorganisation, following font family lines
ⵞ Create compat packages to ease switchover at F11 time (to be discontinued
  for F12)
⬳ compress status file

* Wed Sep 3 2008 Nicolas Mailhot <nicolas.mailhot at laposte.net>
- 2.26-2
⚙ Rebuild with pre-F10-freeze fontforge

* Sun Jul 26 2008 Nicolas Mailhot <nicolas.mailhot at laposte.net>
- 2.26-1
Բ New release at last

* Wed Jul 16 2008 Tom "spot" Callaway <tcallawa@redhat.com>
- 2.25-4
- note Public Domain contributions

* Wed Jul 16 2008 Tom "spot" Callaway <tcallawa@redhat.com>
- 2.25-3
- fix license tag

* Fri Jul 11 2008 <nicolas.mailhot at laposte.net>
- 2.25-2
⌖ Fedora 10 alpha general package cleanup

* Mon May 19 2008 <nicolas.mailhot at laposte.net>
- 2.25-1
❋ 2.25 final

* Fri Apr 4 2008 <nicolas.mailhot at laposte.net>
- 2.24-3
⚕ Fix source URL

* Tue Mar 18 2008 <nicolas.mailhot at laposte.net>
- 2.24-2
✓ rebuild for new fontforge

* Mon Mar 10 2008 <nicolas.mailhot at laposte.net>
☺ 2.24-1
✓ 2.24 final

* Tue Mar 4 2008 <nicolas.mailhot at laposte.net>
☺ 2.24-0.2.rc1
✓ rc time

* Mon Mar 3 2008 <nicolas.mailhot at laposte.net>
☺ 2.24-0.1.20080228svn2189
✓ early 2.24 test build, check new fontforge

* Sun Jan 20 2008 <nicolas.mailhot at laposte.net>
☺ 2.23-1
✓ 2.23 final

* Thu Dec 9 2007 <nicolas.mailhot at laposte.net>
☺ 2.22-1
✓ 2.22 final

* Thu Dec 6 2007 <nicolas.mailhot at laposte.net>
☺ 2.22-0.1.20071206svn2135
✓ 2.22 rc phase started
✓ sync with guidelines

* Sun Oct 28 2007 <nicolas.mailhot at laposte.net>
☺ 2.21-1
✓ 2.21 final

* Sat Oct 27 2007 <nicolas.mailhot at laposte.net>
☺ 2.21-0.4.20071027svn2023
✓ Fedora fontconfig files dropped (merged upstream)

* Wed Oct 25 2007 <nicolas.mailhot at laposte.net>
☺ 2.21-0.3.20071025svn2022
 ✓ Makefile patch dropped (merged upstream)
 ✓ add -f to fc-cache calls
 ✓ completely align LGC and FULL fontconfig rules
 ✓ remove / from directory macros

* Sun Oct 21 2007 <nicolas.mailhot at laposte.net>
☢ 2.21-0.2.20071017svn2019
⚠ Still very experimental version:
  ✓ update makefile patch
  ✓ split lgc hinting file like in the other packages
  ✓ move lgc to prio 58 as should have been done when liberation was added

* Sun Oct 21 2007 <nicolas.mailhot at laposte.net>
☢ 2.21-0.1.20071014svn2016
⚠ Very experimental version to test major changes:
  ✓ new fontforge version
  ✓ use of a real makefile at last
  ✓ replacing standalone lgc package with subpackage generated with the rest

* Tue Sep 18 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.20-1
✓ 2.20 final
✓ bugfix release (Hebrew fixes mostly)

* Sat Aug 11 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.19-1
✓ 2.19 final
✓ expand macro use

* Sun Jul 1 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.18-1
✓ 2.18 final
✓ Major new release adding Tifinagh (ⵞⵥⴼⴻ), N'ko (ߝߧߜ) and Georgian (ლფჱႫႿ)
  (Georgian created by Besarion Paata Gugushvili ბესარიონ პაატა გუგუშვილი)

* Wed Jun 27 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.18-0.2.rc1
✓ 2.18-rc1

* Sun Jun 3 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☢ 2.18-0.1.20070616svn1889
⚠ early snapshot to test new fontforge

* Sun Jun 3 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.17-5
✓ declare DejaVu a valid Bitstream Prima™ substitute

* Thu May 31 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.17-3
✓ small spec cleanups

* Sat May 26 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.17-2
✓ perl-Font-TTF has been fixed upstream, use perl(Font::TTF) BR
✓ remove comment about /etc/fonts/conf.d ownership, as it's now owned
   by filesystem

* Sun May 13 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.17-1
✓ rebase scriptlets from guidelines
✓ fontforge broke compat: BR the current version, ask for a version bump
  before 2.18 is released
✓ simplify font directory naming
✓ clean up fc5 obsoletes
✓ remove technical mes files from doc

* Fri May 11 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.17-0.3.rc1
✓ fontconfig setup has stabilized and can be marked noreplace now
☺ 2.17-0.2.rc1
✓ mimick Vera unhint conf split
☺ 2.17-0.1.rc1
✓ 2.17 rc1
✓ make room for liberations font conf file

* Mon Apr 2 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.16-1

* Tue Mar 20 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.16-0.1.20070319svn1699
✓ early snapshot to account for F7T3 freeze

* Tue Jan 30 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
☺ 2.14-2
✓ Adds Dejavu Sans Oblique small fixes (by Ben Laenen to address Debian
  bug #408311, collected by Davide Viti)

* Sun Jan 21 2007 Nicolas Mailhot <nicolas.mailhot at laposte.net>
✓ 2.14 final