Blob Blame History Raw
# Techincally, we're noarch; but erlang whose directories we install into is not.
%global debug_package %{nil}

Name:           erlang-meck
Version:        0.7.1
Release:        1%{?dist}
Summary:        A mocking library for Erlang
Group:          Development/Libraries
License:        ASL 2.0
URL:            http://eproxus.github.com/meck/
# wget -O eproxus-meck-0.7.1-0-g916844d.tar.gz https://github.com/eproxus/meck/tarball/0.7.1
Source0:        eproxus-meck-0.7.1-0-g916844d.tar.gz
BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires:  erlang-erts
BuildRequires:  erlang-rebar
Requires:       erlang-erts


%description
With meck you can easily mock modules in Erlang. Since meck is intended to be 
used in testing, you can also perform some basic validations on the mocked 
modules, such as making sure no function is called in a way it should not.


%prep
%setup -q -n eproxus-meck-a757081


%build
make %{?_smp_mflags}


%install
rm -rf %{buildroot}
mkdir -p %{buildroot}%{_libdir}/erlang/lib/meck-%{version}/ebin
install -m 644 ebin/meck.app %{buildroot}%{_libdir}/erlang/lib/meck-%{version}/ebin
install -m 644 ebin/*.beam %{buildroot}%{_libdir}/erlang/lib/meck-%{version}/ebin


%clean
rm -rf %{buildroot}


%files
%defattr(-,root,root,-)
%doc LICENSE README.md NOTICE
%dir %{_libdir}/erlang/lib/meck-%{version}
%dir %{_libdir}/erlang/lib/meck-%{version}/ebin
%{_libdir}/erlang/lib/meck-%{version}/ebin/meck.app
%{_libdir}/erlang/lib/meck-%{version}/ebin/*.beam


%changelog
* Mon Feb 13 2012 Lubomir Rintel (GoodData) <lubo.rintel@gooddata.com> - 0.7.1-1
- Rebase
- Review fixes (Peter Lemenkov, #705773)

* Wed May 18 2011 Lubomir Rintel (GoodData) <lubo.rintel@gooddata.com> - 0.5-1
- Initial packaging