Blob Blame History Raw
Name:           frescobaldi
Version:        0.7.8
Release:        1%{?dist}
Summary:        Edit LilyPond sheet music with ease!
Group:          Applications/Editors
# python/hyphenator.py is LGPLv2+
# python/rational.py is public domain
# The rest, including the core of the program, is GPLv2+
License:        GPLv2+ and LGPLv2+ and Public Domain
URL:            http://www.frescobaldi.org/
Source0:        http://lilykde.googlecode.com/files/%{name}-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch:      noarch
BuildRequires:  cmake
BuildRequires:  desktop-file-utils
BuildRequires:  gettext 
BuildRequires:  ImageMagick
BuildRequires:  lilypond
BuildRequires:  PyKDE4

Requires:       alsa-utils
Requires:       lilypond
Requires:       PyKDE4 
Requires:       rumor
Requires:       timidity++
# Need katepart, kdialog, okularpart, ...
Requires:       kdebase
Requires:       kdegraphics
Requires:       kdesdk

%description
Frescobaldi is a LilyPond sheet music editor for KDE4. It aims to be powerful,
yet lightweight and easy to use. It features:

    * Enter LilyPond scores, build and preview them with a mouseclick
    * Point-and-click support: click on notes or error messages to jump to the
      correct position
    * A powerful Score Wizard to quickly setup a musical score
    * Editing tools to:
          o manipulate the rhythm
          o hyphenate lyrics
          o quickly enter or add articulations and other symbols to existing 
            music
          o run the document through convert-ly to update it to a newer 
            LilyPond version
    * Context sensitive autocomplete, helping you to quickly enter LilyPond 
      commands
    * Expansion manager to enter larger snippets of LilyPond input using short
      mnemonics
    * A powerful Rumor plugin, using the Rumor program to quickly enter music
      by playing it on a MIDI keyboard or even your computer keyboard
    * Built-in comprehensive User Guide


%prep
%setup -q

# We want to build everything from source
rm -f po/*.mo
rm -f pics/*.png

%build
%{cmake_kde4} -DKDE4_BIN_INSTALL_DIR=%{_bindir}
make %{?_smp_mflags} VERBOSE=1 

%install
rm -rf %{buildroot}
make install DESTDIR=%{buildroot} 

## File lists
# locale's
%find_lang %{name}
# HTML (1.0)
HTML_DIR=$(kde4-config --expandvars --install html)
if [ -d %{buildroot}$HTML_DIR ]; then
   for lang_dir in %{buildroot}$HTML_DIR/* ; do
      pushd $lang_dir
         # Replace absolute symlinks with relative ones
         for i in *; do
            [ -d $i -a -L $i/common ] && rm -f $i/common && ln -sf ../common $i/common
         done
      popd
   done
fi

# desktop file
desktop-file-install                                         \
   --dir=%{buildroot}%{_datadir}/applications                \
   --remove-category=Application                             \
   --add-category=AudioVideo                                 \
   --delete-original                                         \
   %{buildroot}%{_datadir}/applications/kde4/%{name}.desktop

%clean
rm -rf %{buildroot}

%post
update-desktop-database &> /dev/null || :
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :

%postun
update-desktop-database &> /dev/null || :
if [ $1 -eq 0 ] ; then
    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
fi

%posttrans
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :

%files -f %{name}.lang
%defattr(-,root,root,-)
%doc ChangeLog COPYING README* THANKS
%{_docdir}/HTML/en/%{name}/
%{_bindir}/%{name}
%{_datadir}/applications/%{name}.desktop
%{_datadir}/icons/hicolor/scalable/apps/%{name}.svgz
%{_datadir}/kde4/apps/%{name}/

%changelog
* Tue Mar 24 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> - 0.7.8-1
- New upstream version

* Tue Mar 17 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> - 0.7.7-2
- Remove BuildRequires:  dbus-python
- Fix the year of the previous changelog entry
- Add "Public Domain" to the license tag
- Add AudioVideo category to the .desktop file
- Add disttag

* Sun Mar 15 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> - 0.7.7-1
- Initial build