Blob Blame History Raw
Summary:	Frysk execution analysis tool
Name:		frysk
Version:	0.0.1.2006.08.30.rh1
Release:	2%{?dist}
License:	GPL
Group:		Development/System
URL:		http://sourceware.org/frysk
Source:		%{name}-%{version}.tar.bz2

# Disable the test which fails when building on older kernel.
Patch:		frysk-xfail-2130.patch

BuildRoot:	%{_tmppath}/%{name}-%{version}-root

Requires:   	libglade-java >= 2.12.5
Requires: 	libvte-java >= 0.12.0
Requires:   	libgconf-java
BuildRequires:  gcc-java >= 4.1.1
BuildRequires:	junit >= 3.8.1
BuildRequires:  antlr >= 2.7.4 
BuildRequires:	jdom >= 1.0
BuildRequires:  libgtk-java-devel >= 2.8.4
BuildRequires:	libglade-java-devel >= 2.12.3
BuildRequires:  cairo-java-devel >= 1.0.3
BuildRequires:  cairo-devel >= 1.0.0
BuildRequires:  gtk2-devel >= 2.8.0
BuildRequires:	libglade2-devel >= 2.5.1
BuildRequires:	libgconf-java-devel
BuildRequires:	libvte-java-devel >= 0.12.0
BuildRequires:  vte-devel >= 0.12.1
BuildRequires:  xmlto
BuildRequires:  sharutils
BuildRequires:	transfig >= 3.2.0 
BuildRequires:  dogtail >= 0.5.2
BuildRequires:	gnome-python2-gconf

# Needed by "dogtail-run-headless -n":
Buildrequires:	metacity

ExclusiveArch: %{ix86} x86_64 ppc64

%description
Frysk is an execution-analysis technology implemented using native Java and C++.
It is aimed at providing developers and sysadmins with the ability to both
examine and analyze running multi-host, multi-process, multi-threaded systems.
Frysk allows the monitoring of running processes and threads, of locking
primitives and will also expose deadlocks, gather data and debug any given
process in the system.

%prep
%setup -q -n %{name}-%{version}
%patch

%build 

export JAVAC=${JAVAC:-/usr/bin/gcj -C}
export GCJ=${GCJ:-/usr/bin/gcj}
export GIJ=${GIJ:-/usr/bin/gij}
export JAR=${JAR:-/usr/bin/fastjar}
export GCJH=${GCJH:-/usr/bin/gcjh}
export GCJ_DBTOOL=${GCJ_DBTOOL:-/usr/bin/gcj-dbtool}
export GCC=${GCC:-/usr/bin/gcc}
export CC=${CC:-/usr/bin/gcc}
export CXX=${CXX:-/usr/bin/g++}
export JAVA=${JAVA:-/usr/bin/gij}
export JV_SCAN=${JV_SCAN:-/usr/bin/jv-scan}

gcc --version

# FIXME: Warninggs should be fixed, not suppressed:
RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wp,-D_FORTIFY_SOURCE=2 /}
%configure CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS"

# Build system can end up with corrupt xmllint files:
touch frysk-gui/glade.catalog
touch frysk-gui/glade.checked

make %{?_smp_mflags}

%if 0
%check
uname -a
make %{?_smp_mflags} -k check || :
%endif

%install

rm -rf %{buildroot}
make  DESTDIR=$RPM_BUILD_ROOT  install %{?_smp_mflags}

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root)
%doc COPYING frysk-imports/common/EXCEPTION
%{_bindir}/frysk
%{_bindir}/ftrace
%{_libdir}/*so*
%dir %{_datadir}/%{name}
%{_datadir}/%{name}/*   
%{_datadir}/java/*.jar
%{_datadir}/applications/frysk.desktop
%{_datadir}/pixmaps/fryskTrayIcon48.png
%{_mandir}/man*/*
%{_libexecdir}/frysk/*

%changelog
* Sat Sep  2 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.08.30.rh1-2
- Tried to build on 32bit ppc, but it does not work yet.

* Tue Aug 29 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.08.30.rh1-1
- New upstream version.
- Removed xorg-x11-xinit from BuildRequires, dogtail was fixed to require it.
- Build also on ppc64.

* Mon Aug 28 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.08.28.rh1-1
- New upstream version.
- Remove Patch1, the code now contains a real fix for bug #203902.

* Fri Aug 25 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.08.24.rh1-3
- Patch1 for bug #203902.

* Fri Aug 25 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.08.24.rh1-2
- Comment out the %%check section temporarily.

* Thu Aug 24 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.08.24.rh1-1
- New upstream version.
- Add Requires: libgconf-java

* Tue Aug 22 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.08.22.rh1-1
- New upstream version.
- Add BuildRequires: gnome-python2-gconf, remove BuildRequires: ghostscript.
- Add `uname -a' to %%check.

* Wed Aug 16 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.08.16.rh1-1
- New upstream version.

* Tue Aug 15 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.08.15.rh1-1
- New upstream version.
- Require latest java-gnome.
- frysk-xfail-2130.patch: fails if building on an old kernel.

* Wed Aug  9 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.08.09.rh1-1
- New upstream version, incorporates both the patches.

* Wed Aug  2 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.07.25.rh1-4
- Add make check to %%check
- Add patches to disable failing tests.

* Wed Aug  2 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.07.25.rh1-3
- BuildRequires latest dogtail

* Fri Jul 28 2006 Phil Muldoon <pmuldoon@redhat.com> -  0.0.1.2006.07.25.rh1-3
- Add dogtail to BuildRequires 

* Tue Jul 25 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.07.25.rh1-2
- Add ftrace to the file list.

* Tue Jul 25 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.07.25.rh1-1
- New upstream version.

* Sat Jul 22 2006 Thomas Fitzsimmons <fitzsim@redhat.com> - 0.0.1.2006.07.18.rh1-2
- Bump release number. (dist-fc6-java)

* Tue Jul 18 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.07.18.rh1-1
- New upstream version, incorporates the previous two patches.

* Wed Jul 18 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.07.14.rh1-2
- Add two patches from Phil Muldoon:
  frysk-20060714-observer.patch -- continue even though an observer cannot be load
  frysk-20060714-timer.patch -- fix incorrect usage of a core timer

* Wed Jul 14 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.07.14.rh1-1
- New upstream version.

* Wed Jul 13 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.07.13.rh1-1
- New upstream version.

* Wed Jul 12 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.07.12.rh2-1
- New upstream version.

* Wed Jul 12 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.07.12.rh1-1
- New upstream version.

* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.0.1.2006.06.28.rh1-0.1
- rebuild

* Wed Jun 28 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.06.28.rh1-1
- Remove  BuildRequires:  autoconf automake

* Tue Jun 27 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.06.28.rh1-0
- Refresh the tarball.
- Remove the patches, they are all upstream now.
- BuildRequires: sharutils, instead of gmime.
- Do not remove the unwanted files, they should not be installed anymore.
- Do not hide the menu entry.
- Do not call ./bootstrap.sh.

* Fri Jun 16 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.06.15-3
- Add the non-intermediate hack.
- Remove more unwanted files.
- Add patch to link statically with libelf; remove elfutils libraries.

* Fri Jun 16 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.06.15-2
- Suppress warnings caused by _FORTIFY_SOURCE=2
- Remove unwanted files.

* Fri Jun 16 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.06.15-1
- Add BuildRequires: libgconf-java-devel
- Update frysk-unistd.patch

* Thu Jun 15 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.06.15-0
- Refresh the tarball.
- Patch to fix Elf.cxx on 64bit.
- Anoter patch required by new linux/unistd.h.
- Add BuildRequires: ghostscript

* Thu Jun 15 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.06.14-1
- Patch for new linux/unistd.h.
- Patch to avoid scanf("%%a[..]").

* Thu Jun 14 2006 Stepan Kasal <skasal@redhat.com> - 0.0.1.2006.06.14-0
- New upstream version.
- Add BuildRequires: libglade2-devel >= 2.5.1
- Refresh other BuildRequires.
- Replace the noxmltest.patch patch by two touch commands.
- Add BuildRequires: autoconf automake, BuildRequires: gcc-java >= 4.1.1

* Thu May 18 2006 Stepan Kasal <skasal@redhat.com>    - 0.0.1.2006.02.19.rh2-0.FC5.3
- Add gmime to BuildRequires.

* Fri Mar 03 2006 Andrew Cagney <cagney@redhat.de> 0.0.1.2006.02.19.rh2-0.FC5.2
- Add Hidden=true to frysk.desktop file; from halfline; with fixes.
- Disable xml check in frysk-gui/.

* Wed Mar 01 2006 Andrew Cagney <cagney@redhat.de> 0.0.1.2006.02.19.rh2-0.FC5.1
- Add dependencies on latest Java-GNOME bindings.

* Wed Mar 01 2006 Andrew Cagney <cagney@redhat.de> 0.0.1.2006.02.19.rh2-0.FC5.0
- Import frysk 0.0.1.2006.02.19.rh2; works around bug #180637.
- Enable x86_64, update *-java BuildRequires; fix bug #183538.

* Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 0.0.1.2006.02.19.rh1-0.FC5.1
- BuildRequires: xmlto

* Mon Feb 20 2006 Andrew Cagney <cagney@redhat.com> 0.0.1.2006.02.19.rh1-0.FC5.0
- Import frysk 0.0.1.2006.02.19.rh1 -- snapshot from middle of that day.

* Sat Feb 18 2006 Andrew Cagney <cagney@redhat.com> 0.0.1.2006.02.12-0.FC5.1
- Remove eclipse-cdt >= 3.0.0 from BuildRequires.  From Wu Zhou
  woodzltc@ibm.

* Sun Feb 12 2006 Andrew Cagney <cagney@redhat.com> 0.0.1.2006.02.12-0.FC5.0
- Import frysk 0.0.1.2006.02.12.

* Thu Feb 09 2006 Adam Jocksch <ajocksch@redhat.com> 0.0.1.2006.02.09-0.FC5.0
- Removed ftrace from %%files and added libexedir files and man pages.
- Imported new frysk tarball, 

* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.0.1.2006.01.22-0.FC5.1.1
- rebuilt for new gcc4.1 snapshot and glibc changes

* Mon Feb 06 2006 Adam Jocksch <ajocksch@redhat.com> 0.0.1.2006.01.22-0.FC5.1
- Bumped version, rebuilt.

* Mon Jan 23 2006 Andrew Cagney <cagney@redhat.com> 0.0.1.2006.01.22-0.FC4.0
- Simplify .spec file (remove unused macro definitions).
- Import frysk 0.0.1.2006.01.22.
- Update -files; adding frysk.desktop and fryskTrayIcon48.png.

* Thu Dec 22 2005 Andrew Cagney <cagney@redhat.com> 0.0.1.2005.12.14.15.12-0.FC4.1
- Import frysk-0.0.1.2005.12.14.15.12 rpm.
- Drop build dependency java-1.4.2-gcj-compat-devel
- Apply Patch003, frysk-makefileam.patch.

* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt

* Mon Nov 16  2005 Igor Foox <ifoox@redhat.com> 0.0.0.20051116-0.3
- Added jars under /usr/share/java to distribution.

* Mon Nov 16  2005 Igor Foox <ifoox@redhat.com> 0.0.0.20051116-0.1
- Update source.

* Mon Nov 16  2005 Igor Foox <ifoox@redhat.com> 0.0.0.20051114-0.3
- Removed runtime dependency for eclipse-cdt, changed buildtime eclipse-cdt dependency to 3.0.0.

* Mon Nov 16  2005 Igor Foox <ifoox@redhat.com> 0.0.0.20051114-0.2
- Changed dependency on frysk-cdtparser to eclipse-cdt (it was somehow magically reversed).

* Mon Nov 14  2005 Igor Foox <ifoox@redhat.com> 0.0.0.20051114-0.1
- Removed smp flags.

* Mon Nov 10  2005 Igor Foox <ifoox@redhat.com> 0.0.0.20051109-0.3
- Update source.

* Wed Nov 10  2005 Igor Foox <ifoox@redhat.com> 0.0.0.20051109-0.2
- Added ExclusiveArch for i386.

* Wed Nov 10  2005 Igor Foox <ifoox@redhat.com> 0.0.0.20051109-0.1
- Updated source, changed cdtparser dependency to eclipse-cdt. Added build
restriction to i386. Added %%{?_smp_flags} to make command.

* Fri Oct 28  2005 Igor Foox <ifoox@redhat.com> 0.0-2
- Validated all Requires and BuildRequires clauses, fixed some of them.
- Fixed bug with libdir detection based on architecture.

* Wed Oct 26  2005 Igor Foox <ifoox@redhat.com> 0.0-1
- Birth.