Blob Blame History Raw
# https://fedoraproject.org/wiki/Packaging:Haskell

%global pkg_name entropy

# Setup uses TH
%global ghc_without_dynamic 1

Name:           ghc-%{pkg_name}
Version:        0.2.2.1
Release:        1%{?dist}
Summary:        A platform independent entropy source

License:        BSD
URL:            http://hackage.haskell.org/package/%{pkg_name}
Source0:        http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz

BuildRequires:  ghc-Cabal-devel
BuildRequires:  ghc-rpm-macros
# Begin cabal-rpm deps:
BuildRequires:  ghc-bytestring-devel
# End cabal-rpm deps
# Setup uses TH
ExclusiveArch:  %{ghc_arches_with_ghci}
BuildRequires:  ghc-template-haskell-devel

%description
A platform independent method to obtain cryptographically strong entropy
(urandom on Linux, CryptAPI on Windows, patches welcome).
Users looking for cryptographically strong (number-theoretically
sound) PRNGs should see the 'DRBG' package too!.


%package devel
Summary:        Haskell %{pkg_name} library development files
Requires:       ghc-compiler = %{ghc_version}
Requires(post): ghc-compiler = %{ghc_version}
Requires(postun): ghc-compiler = %{ghc_version}
Requires:       %{name} = %{version}-%{release}

%description devel
This package provides the Haskell entropy library development files.


%prep
%setup -q -n %{pkg_name}-%{version}


%build
%ghc_lib_build


%install
%ghc_lib_install


%post devel
%ghc_pkg_recache


%postun devel
%ghc_pkg_recache


%files -f %{name}.files
%doc LICENSE


%files devel -f %{name}-devel.files


%changelog
* Fri Jun 14 2013 Jens Petersen <petersen@redhat.com> - 0.2.2.1-1
- update to 0.2.2.1
- Setup now uses Template Haskell
- update to new simplified Haskell Packaging Guidelines

* Wed Feb 13 2013 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 0.2.1-1
- spec file generated by cabal-rpm-0.7.1