Blob Blame History Raw
# Generated by go2rpm 1
%bcond_without check

# https://gitea.com/goftp/server
%global goipath         goftp.io/server
%global forgeurl        https://gitea.com/goftp/server
Version:                0.3.4
%global repo            server
%global archivename     v%{version}
%global archiveext      tar.gz
%global archiveurl      %{forgeurl}/archive/v%{version}.%{archiveext}
%global topdir          %{repo}
%global extractdir      %{repo}
%global scm             git

%gometa

%global goaltipaths     github.com/goftp/server

%global common_description %{expand:
A FTP server framework written in Go.}

%global golicenses      LICENSE
%global godocs          README.md

Name:           %{goname}
Release:        1%{?dist}
Summary:        FTP server framework written in Go

License:        MIT
URL:            %{gourl}
Source0:        %{gosource}

BuildRequires:  golang(github.com/minio/minio-go)

%if %{with check}
# Tests
BuildRequires:  golang(github.com/jlaffaye/ftp)
BuildRequires:  golang(github.com/stretchr/testify/assert)
%endif

%description
%{common_description}

%gopkg

%prep
%goprep
sed -i "s|github.com/minio/minio-go/v6|github.com/minio/minio-go|" $(find . -type f -iname "*.go")

%install
%gopkginstall

%if %{with check}
%check
%gocheck
%endif

%gopkgfiles

%changelog
* Tue Jun 30 16:08:39 CEST 2020 Robert-André Mauchin <zebob.m@gmail.com> - 0.3.4-1
- Initial package