Blob Blame History Raw
# Generated by go2rpm 1
%bcond_without check
%global debug_package %{nil}

# https://github.com/kubernetes/kubectl
%global goipath         k8s.io/kubectl
%global forgeurl        https://github.com/kubernetes/kubectl
Version:                1.22.0
%global tag             kubernetes-1.22.0
%global distprefix      %{nil}

%gometa

%global common_description %{expand:
Issue tracker and mirror of kubectl code.}

%global golicenses      LICENSE
%global godocs          docs CONTRIBUTING.md README.md code-of-conduct.md

Name:           %{goname}
Release:        %autorelease
Summary:        Issue tracker and mirror of kubectl code

# Upstream license specification: Apache-2.0
License:        ASL 2.0
URL:            %{gourl}
Source0:        %{gosource}
Patch0:         0001-Update-chai2010-gettext-go-to-1.0.2.patch


%description
%{common_description}

%gopkg

%prep
%goprep
%patch -P0 -p1
sed -i 's|github.com/russross/blackfriday|gopkg.in/russross/blackfriday.v1|' $(find . -iname "*.go" -type f)

%generate_buildrequires
%go_generate_buildrequires

%install
%gopkginstall

%if %{with check}
%check
%gocheck -t pkg/cmd
%endif

%gopkgfiles

%changelog
%autochangelog