Blob Blame History Raw
# Generated by go2rpm 1.8.0
%bcond_without check

# https://github.com/mvdan/gofumpt
%global goipath         mvdan.cc/gofumpt
%global forgeurl        https://github.com/mvdan/gofumpt
Version:                0.3.1

%gometa

%global common_description %{expand:
A stricter gofmt.}

%global golicenses      LICENSE LICENSE.google
%global godocs          README.md

Name:           %{goname}
Release:        %autorelease
Summary:        A stricter gofmt

License:        BSD-3-Clause
URL:            %{gourl}
Source:         %{gosource}

%description %{common_description}

%gopkg

%prep
%goprep

%generate_buildrequires
%go_generate_buildrequires

%build
%gobuild -o %{gobuilddir}/bin/gofumpt %{goipath}

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
%gocheck
%endif

%files
%license LICENSE LICENSE.google
%doc CHANGELOG.md README.md
%{_bindir}/gofumpt

%gopkgfiles

%changelog
%autochangelog