Blob Blame History Raw
# Generated by go2rpm 1.6.0
%bcond_without check
%global debug_package %{nil}

# https://github.com/census-instrumentation/opencensus-go
%global goipath         go.opencensus.io
%global forgeurl        https://github.com/census-instrumentation/opencensus-go
Version:                0.23.0

%gometa

%global common_description %{expand:
OpenCensus Go is a Go implementation of OpenCensus, a toolkit for collecting
application performance and behavior monitoring data. Currently it consists of
three major components: tags, stats and tracing.}

%global golicenses      LICENSE
%global godocs          examples AUTHORS CONTRIBUTING.md README.md example example example

Name:           %{goname}
Release:        %autorelease
Summary:        Stats collection and distributed tracing framework

License:        Apache-2.0
URL:            %{gourl}
Source0:        %{gosource}

%description
%{common_description}

%gopkg

%prep
%goprep

%generate_buildrequires
%go_generate_buildrequires
echo 'golang(github.com/stretchr/testify/assert)'

%install
%gopkginstall

%if %{with check}
%check
for test in "TestAgainstSpecs" \
            "TestServerSpanDuration" \
            "Test_Worker_MultiExport" \
; do
awk -i inplace '/^func.*'"$test"'\(/ { print; print "\tt.Skip(\"disabled failing test\")"; next}1' $(grep -rl $test)
done
%gocheck
%endif

%gopkgfiles

%changelog
%autochangelog