Blob Blame History Raw
### global bootstrap_arch  %{GPRbuild_arches}
%global bootstrap_arch  no_bootstraping

# When bootstrapping GPRbuild for a new architecture, set bootstrap_arch to the
# name of that architecture and add a tarball with binaries as Source100.
# When not bootstrapping bootstrap_arch must have a nonempty value that isn't
# an architecture name, as this spec would be syntactically invalid otherwise.
#
# Bootstrapping exception: https://fedorahosted.org/fpc/ticket/605
%ifarch %{bootstrap_arch}
%global debug_package %{nil}
%endif
# Stripping out debugging information isn't important when bootstrapping, and
# skipping this allows one to avoid unnecessary efforts to produce unstripped
# binaries to bootstrap with.
%ifnarch %{bootstrap_arch}
%define with_libgpr 1
%else
%define with_libgpr 0
%endif
%global _python_bytecompile_extra 0

# Upstream source information.
%global upstream_owner         AdaCore
%global upstream_name          gprbuild
%global upstream_version       22.0.0
%global upstream_release_date  20211028
%global upstream_gittag        v%{upstream_version}

Name:           gprbuild
Epoch:          2
Version:        %{upstream_version}
Release:        1%{?dist}
Summary:        Ada project builder

License:        GPL-3.0-or-later WITH GCC-exception-3.1 AND Unicode-DFS-2016
# GPRbuild itself is licensed under GPL v3 or later with a runtime
# exception, but is statically linked to both the GNAT runtime library
# and the XML/Ada library to prevent the package from breaking when
# GCC is being updated.
#
# - The GNAT runtime library is licensed under the the same license
#   and exception: GPL v3 or later with a runtime exception.
#
# - XML/Ada is also licensed under the same GPL v3 or later and
#   runtime exception, but also mentions the Unicode license as
#   Unicode data files are used as an input for generating some of
#   XML/Ada's source code.

URL:            https://github.com/%{upstream_owner}/%{upstream_name}
Source0:        %{url}/archive/%{upstream_gittag}/%{upstream_name}-%{upstream_version}.tar.gz
# For testing.
Source1:        gprbuild-sanity.tar.gz

# [Fedora specific] The GPRconfig KB is already available when bootstrapping.
Patch:          %{name}-dont-reinstall-the-gprconfig-kb.patch
# [Fedora specific] Remove unnecessary indirection.
Patch:          %{name}-drop-exe-prefix.patch
# [Fedora specific] Set the library so version.
Patch:          %{name}-set-library-so-version.patch

# [Fedora specific] Resolve naming conflict with libraries for Google gRPC.
#    GPRbuild and Google's gRPC both want the filename "libgpr.so". This patch
#    renames the library to "libgnatprj.so" to resolve the conflict. The name is
#    chosen for consistency with Debian.
Patch:          %{name}-resolve-libgpr-conflict.patch

# [Fedora specific] Follow soft links when resolving the compiler driver.
#    This usrmove patch works for this package. Upstream a different solution
#    would be needed to handle other possible setups.
Patch:          %{name}-usrmove.patch

BuildRequires:  gcc-gnat > 5.1
BuildRequires:  libgnat-static
BuildRequires:  fedora-gnat-project-common
BuildRequires:  make

%ifarch %{bootstrap_arch}
BuildRequires:  gprconfig-kb
BuildRequires:  xmlada-sources
%else
BuildRequires:  gprbuild
# xmlada-devel must be explicitly specified for first build after bootstrap.
BuildRequires:  xmlada-devel
BuildRequires:  xmlada-static
BuildRequires:  python3-sphinx
BuildRequires:  texinfo
%endif

%ifnarch %{bootstrap_arch}
# Build only on architectures where GPRbuild is already available,
# plus the architecture being bootstrapped, if any.
ExclusiveArch:  %{GPRbuild_arches} %{bootstrap_arch}
%endif

Requires:       gprconfig-kb
Requires:       fedora-gnat-project-common
Requires:       gnat-srpm-macros

%description
GPRbuild is an advanced software tool designed to help automate
the construction of multi-language systems.
It removes complexity from multi-language development by allowing
developers to quickly and easily compile and link software written
in a combination of languages including Ada, Assembler, C, C++, and Fortran.
Easily extendable by users to cover new toolchains and languages
it is primarily aimed at projects of all sizes organized into subsystems
and libraries and is particularly well-suited for compiled languages.

%ifnarch %{bootstrap_arch}
%package doc
Summary:        Documentation for GPRbuild
Requires:       %{name} = %{epoch}:%{version}-%{release}
License:        GFDL-1.3-no-invariants-or-later AND MIT AND BSD-2-Clause AND GPL-3.0-or-later WITH GCC-exception-3.1 AND GPL-3.0-or-later WITH GNAT-exception
# The license of the documentation itself is GFDL 1.3. Some Javascript and CSS
# files that Sphinx includes with the documentation are BSD 2-Clause and
# MIT-licensed. Some examples are licensed under GPL 3.0 or later with GCC
# runtime exception, some other examples are licensed under GPL 3.0 or later
# with GNAT exception.

%description doc
%{summary}
%endif

%if %{with_libgpr}
%package -n libgpr
# The source file headers indicate that its name is "GPR Project Manager".
Summary:        GPR Project Manager library
License:        GPL-3.0-or-later WITH GCC-exception-3.1
Requires:       %{name}%{?_isa} = %{epoch}:%{version}-%{release}
Provides:       libgnatprj

%description -n libgpr
The GPR Project Manager is an Ada library for handling GNAT project files. It is
part of GPRbuild.

This is not the libgpr that is part of GRPC from Google.

%package -n libgpr-devel
Summary:        Development files for the GPR Project Manager
Requires:       libgpr%{?_isa} = %{epoch}:%{version}-%{release}
Provides:       libgnatprj-devel

%description -n libgpr-devel
The GPR Project Manager is an Ada library for handling GNAT project files. It is
part of GPRbuild.

The libgpr-devel package contains source code and linking information for
developing applications that use the GPR Project Manager.

This is not the libgpr that is part of GRPC from Google.
%endif

%prep
%autosetup -p1

# Update some release specific information in the source code. The substitutions
# are scoped to specific lines to increase the chance of detecting code changes
# at this point. Sed should exit with exit code 0 if the substitution succeeded
# (using `t`, jump to end of script) or exit with a non-zero exit code if the
# substitution failed (using `q1`, quit with exit code 1).
sed --in-place \
    --expression='33 { s,18.0w,%{upstream_version},         ; t; q1 }' \
    --expression='36 { s,19940713,%{upstream_release_date}, ; t; q1 }' \
    --expression='38 { s,"2016",Date (1 .. 4),              ; t; q1 }' \
    --expression='43 { s,Gnatpro,GPL,                       ; t; q1 }' \
    gpr/src/gpr-version.ads

%build
%ifarch %{bootstrap_arch}
## Some useful output
gcc -v
gcc -dumpmachine
gcc -dumpversion
gnatls -v --version
##

# Additional flags to make executables position independent.
%global Gnatmake_flags_pie -cargs -fPIC -largs -pie -lgnarl_pic -lgnat_pic

export GNATMAKEFLAGS='%{Gnatmake_flags} %{Gnatmake_flags_pie}'

# This will build the bootstrapped binaries.
./bootstrap.sh \
    --with-xmlada=%{_includedir}/xmlada/sources/ \
    --prefix=%{buildroot}%{_prefix}/ \
    build

%else

# Additional flags to make executables position independent. Note that the tools
# are still statically linked to prevent them from breaking when updating to a
# new GCC release.
%global GPRbuild_flags_pie -cargs -fPIC -largs -pie -lgnarl_pic -lgnat_pic -gargs

gprbuild -v -p %{GPRbuild_flags} %{GPRbuild_flags_pie} \
         -XBUILD=production -XLIBRARY_TYPE=static-pic -XVERSION=%{version} \
         -P gprbuild.gpr

%if %{with_libgpr}
gprbuild -v -p %{GPRbuild_flags} \
         -XBUILD=production -XLIBRARY_TYPE=relocatable -XVERSION=%{version} \
         -P gpr/gpr.gpr
%endif

# Make the documentation.
# -- no PDF as `sphinxmulticell.sty` is not provided by any package.
make -C doc html txt info

%endif

%ifarch %{bootstrap_arch}
%check
tar -xvf %{SOURCE1}
PATH="%{buildroot}/%{_bindir}:$PATH" gprbuild -P ./gprbuild-tests/tests_shared.gpr
%endif

%install
%{?filter_setup:
%filter_requires_in %{_libdir}
%filter_requires_in %{_bindir}
%filter_setup
}
%ifarch %{bootstrap_arch}
bash -x ./bootstrap.sh --with-xmlada=%{_includedir}/xmlada/sources/ --prefix=%{buildroot}/%{_prefix}/ install
exit 0
%endif
rm -rf %{buildroot}
%ifarch %{bootstrap_arch}
export PATH="$PWD/bin/:${PATH}"
export INSTALLER="$PWD/bin/gprinstall"
%endif

# Install the external tools.
gprinstall --create-missing-dirs --no-manifest \
           --prefix=%{buildroot}%{_prefix} \
           --install-name=gprbuild --mode=usage \
           -XBUILD=production -XINSTALL_MODE=nointernal -XVERSION=%{version} \
           -P gprbuild.gpr

# Install the internal tools.
gprinstall --create-missing-dirs --no-manifest \
           --prefix=%{buildroot}%{_prefix} \
           --install-name=gprbuild --mode=usage \
           -XBUILD=production -XINSTALL_MODE=internal -XVERSION=%{version} \
           -P gprbuild.gpr

%if %{with_libgpr}

# Install the library.
gprinstall --create-missing-dirs --no-manifest --no-build-var \
           --prefix=%{buildroot}%{_prefix} \
           --sources-subdir=%{buildroot}%{_includedir}/libgpr \
           --project-subdir=%{buildroot}%{_GNAT_project_dir} \
           --ali-subdir=%{buildroot}%{_libdir}/libgpr \
           --lib-subdir=%{buildroot}%{_libdir} \
           --link-lib-subdir=%{buildroot}%{_libdir} \
           -XBUILD=production -XLIBRARY_TYPE=relocatable -XVERSION=%{version} \
           -P gpr/gpr.gpr

# Fix up the symbolic links for the shared libraries.
ln --symbolic --force libgnatprj.so.%{version} %{buildroot}%{_libdir}/libgnatprj.so

%endif

# Install the Info version of the manual where Info files belong.
mv --no-target-directory %{buildroot}%{_pkgdocdir}/info %{buildroot}%{_infodir}

# Move the examples to the _pkgdocdir and remove the remaining empty directory.
mv %{buildroot}%{_datadir}/examples/%{name} %{buildroot}%{_pkgdocdir}/examples
rmdir %{buildroot}%{_datadir}/examples

%files
%license COPYING3 COPYING.RUNTIME
%doc README*
%{_bindir}/gpr*
%dir %{_libexecdir}/%{name}
%{_libexecdir}/%{name}/gpr*
%attr(444,-,-) %{_GNAT_project_dir}/_default.gpr
# Exclude installation script; it serves no purpose in this context.
%exclude %{_prefix}/doinstall

%if %{with_libgpr}
%files -n libgpr
%{_libdir}/libgnatprj.so.%{version}

%files -n libgpr-devel
%{_GNAT_project_dir}/gpr.gpr
%{_includedir}/libgpr
%dir %{_libdir}/libgpr
%attr(444,-,-) %{_libdir}/libgpr/*.ali
%{_libdir}/libgnatprj.so
%endif

%ifnarch %{bootstrap_arch}
%files doc
%{_infodir}/*
%dir %{_pkgdocdir}
%{_pkgdocdir}/html
%{_pkgdocdir}/txt
%{_pkgdocdir}/examples
# Remove Sphinx-generated files that aren't needed in the package.
%exclude %{_pkgdocdir}/html/.buildinfo
%exclude %{_pkgdocdir}/html/objects.inv
%endif

%changelog
* Sun Feb 12 2023 Dennis van Raaij <dvraaij@fedoraproject.org> - 2:22.0.0-1
- Updated to v22.0.0, using the archive available on GitHub.
- Changed the epoch to mark the new upstream version scheme.
- Changed the epoch to 2 instead of 1 for consistency with the GNATcoll packages.
- GPRconfig knowledge files are know packaged separately (gprconfig-kb).
- Removed patch fedora_arches.xml; now part of gprconfig-kb.
- Removed patch gprbuild-2016-gcc7.patch; now part of gprconfig-kb.
- Removed patch gprbuild-2017-bootstrap.patch; has been fixed upstream (commit: 81c0d3d).
- Removed patch gprbuild-2017-fedora_compilers.patch; now part of gprconfig-kb.
- Removed patch gprbuild-2017-libsubdir.patch; Makefile is no longer used to build package.
- Removed patch gprbuild-2020-case_util_conflicts.patch; has been fixed upstream (commit: d803338).
- Removed patch gprbuild-symlinked_dirs.patch; has been fixed upstream (commit: 685aa45).
- Removed patch gprbuild-handle-version-gcc5-and-later.patch; GCC 4 and earlier are no longer supported.
- Fixed a typo in the if-block that switches the ExclusiveArch tag.
- Changed build kind from 'debug' to 'production'.
- Tools are now position independent executables (PIE).
- Added a new build dependency to build the documentation with Sphinx.
- Moved documentation and examples into the _pkgdocdir.
- Subpackages now inherit license from main package (except the doc package).
- Updated the license of the doc package.
- Added a runtime exception for all other packages, following upstream.
- Added the Unicode license as gprbuild is statically linked to xmlada.
- License fields now contain SPDX license expressions.
- Fixed the symbolic links for the shared libraries.
- Fixed the so-version of libgnatprj.so.
- Subpackage libprj now provides libgnatprj.
- Subpackage libprj-devel now provides libgnatprj-devel.
- Some release specific information in the source code is now updated during prep.
- Moved the license files into the correct location.

* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2020-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Tue Jan 17 2023 Björn Persson <Bjorn@Rombobjörn.se> - 2020-12
- Rebuilt with GCC 13.

* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2020-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Sun Jun 05 2022 Björn Persson <Bjorn@Rombobjörn.se> - 2020-10
- Fixed the location of the Info file.

* Wed Feb 02 2022 Björn Persson <Bjorn@Rombobjörn.se> - 2020-9
- Added workarounds to be able to build with GCC 12 prerelease.

* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2020-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Fri Apr 02 2021 Björn Persson <Bjorn@Rombobjörn.se> - 2020-6
- rebuilt with gcc-11.0.1-0.3

* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2020-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild

* Tue Dec  8 2020 Pavel Zhukov <pzhukov@redhat.com> - 2020-4
- Workaround for possible gcc bug 

* Tue Dec  8 2020 Pavel Zhukov <pzhukov@redhat.com> - 2020-3
- Fix builds of symlinked projects

* Mon Dec  7 2020 Pavel Zhukov <pzhukov@redhat.com> - 2020-1
- New version 2020. Rebuild with new gnat

* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2018-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Mon Feb  3 2020 Pavel Zhukov <pzhukov@redhat.com> - 2018-16
- rebuild grpuild

* Mon Feb  3 2020 Pavel Zhukov <pzhukov@redhat.com> - 2018-15
- Bootstrap with gcc10

* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2018-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2018-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Sun Feb 10 2019 Pavel Zhukov <pzhukov@redhat.com> - 2018-12
- Normal build (non bootstrap'ed)

* Sun Feb 10 2019 Pavel Zhukov <pzhukov@redhat.com> - 2018-11
- Fix target for armv7hl

* Sat Feb  9 2019 Pavel Zhukov <pzhukov@redhat.com> - 2018-9
- Rebuild with new gnat-srpm-macros
- Enable sanity tests for bootstrap arches

* Tue Feb  5 2019 Pavel Zhukov <pzhukov@redhat.com> - 2018-7
- Add simple tests
- Build with fedora flags
- Add canonical names for targetsets

* Tue Feb  5 2019 Pavel Zhukov <pzhukov@redhat.com> - 2018-3
- Bootstrap for all arches

* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2017-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2017-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Tue Jun 19 2018 Pavel Zhukov <pzhukov@redhat.com> - 2017-14
- Do not byte-compile python

* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2017-13
- Escape macros in %%changelog

* Tue Feb 06 2018 Pavel Zhukov <landgraf@fedoraproject.org - 2017-12
- rebuilt

* Tue Aug  1 2017 Pavel Zhukov <pzhukov@redhat.com> - 2017-11
- Specify Ada is default language.

* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2017-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild

* Wed Jul 19 2017 Pavel Zhukov <landgraf@fedoraproject.org> - 2017-8
- Enable libgpr. Add subpackage.
- Move gpr.gpr to libgpr-devel
- Move ALIs to devel

* Sat Jul 15 2017 Pavel Zhukov <pzhukov@redhat.com> - 2017-6
- Disable bootstrap for all arches

* Sat Jul 15 2017 Pavel Zhukov <landgraf@fedoraproject.org> - 2017-5
- Use upstream bootstrap
- Enable bootstrap for all %%{GPRbuild_arches}

* Fri Jul 14 2017 Pavel Zhukov <landgraf@fedoraproject.org> - 2017-2
- New version 2017
- Drop dev suffix

* Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 2016-7
- Rebuild due to bug in RPM (RHBZ #1468476)

* Thu Feb 16 2017 Björn Persson <Bjorn@Rombobjörn.se> - 2016-6
- Reverted the temporary workaround.

* Mon Feb 13 2017 Björn Persson <Bjorn@Rombobjörn.se> - 2016-5
- Patched the GPRconfig knowledge base to adapt to a change in GCC's version numbering.
- Made a temporary workaround to rebuild with GCC 7 prerelease.

* Sun Feb  5 2017 Pavel Zhukov <pavel@zhukoff.net> - 2016-3
- Rebuild with new gnat

* Wed Nov 02 2016 Maxim Reznik <reznikmm@gmail.com> - 2016-3
- Fix mingw32 targets to match one from fedora packages
- Fix mingw patch conflict

* Sun Aug 07 2016 Björn Persson <Bjorn@Rombobjörn.se> - 2016-1
- Upgraded to the 2016 release.
- The license has changed to GPLv3+.

* Sun Apr 17 2016 Björn Persson <Bjorn@Rombobjörn.se> - 2015-13
- Added target patterns to make GPRconfig recognize the native GCC on Fedora's
  secondary architectures.
- Re-bootstrapped on ppc64.
- Bootstrapped on ppc64le.

* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2015-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

* Mon Feb 01 2016 Björn Persson <Bjorn@Rombobjörn.se> - 2015-8
- Re-bootstrapped on ARM.

* Tue Jan 19 2016 Björn Persson <Bjorn@Rombobjörn.se> - 2015-6
- GPRbuild no longer requires XMLada as it's statically linked in.

* Tue Jan 19 2016 Björn Persson <Bjorn@Rombobjörn.se> - 2015-5
- Build only on x86 and x86-64.

* Wed Dec 23 2015 Björn Persson <Bjorn@Rombobjörn.se> - 2015-4
- Changed to static linking.

* Thu Jun 25 2015  Pavel Zhukov  <landgraf@fedoraproject.org> - 2015-3
- Remove disabling of autorequires 

* Thu Jun 25 2015  Pavel Zhukov  <landgraf@fedoraproject.org> - 2015-2
- Add xmlada to requires. Missed by disable autorequires

* Thu Jun 25 2015  Pavel Zhukov  <landgraf@fedoraproject.org> - 2015-1
- New Release (#2015)

* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2014-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

* Wed Jun 03 2015 Pavel Zhukov  <landgraf@fedoraproject.org> - 2014-8
- Modify usrmove patch

* Sun May 24 2015 Pavel Zhukov  <landgraf@fedoraproject.org> - 2014-7
- Ship gnat 5.1 headers

* Mon May  4 2015 Peter Robinson <pbrobinson@fedoraproject.org> 2014-6
- Don't build ADA hardened

* Sat May 02 2015 Björn Persson <bjorn@rombobjörn.se> - 2014-5
- Fixed a bug that threw away GCC options that begin with "-m".

* Sun Mar 29 2015 Pavel Zhukov <landgraf@fedoraproject.org> - 2014-4
- New release (2014)
- Fix library version 

* Sun Feb 15 2015 Pavel Zhukov <landgraf@fedoraproject.org> - 2013-16
- Remove OpenVMS from supported OS

* Sat Feb 14 2015 Pavel Zhukov <landgraf@fedoraproject.org> - 2013-15
- Rebuild with new gcc 5.0

* Mon Nov 10 2014 Peter Robinson <pbrobinson@fedoraproject.org> 2013-14
- Update config.sub and config.guess for new architectures

* Sat Oct 11 2014 Pavel Zhukov <landgraf@fedoraproject.org> - 2013-13
- Add gnat-srpm-macros as dependency
 
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2013-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild

* Mon Jun 09 2014 Pavel Zhukov <landgraf@fedoraproject.org> - 2013-11
- Add arm to compillers list

* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2013-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Tue May 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 2013-8
- Use GNAT_arches rather than an explicit list

* Wed May  7 2014 Pavel Zhukov <landgraf@fedoraproject.org> - 2013-7
- Rebuild with new libgnat

* Mon Nov 18 2013 Pavel Zhukov <landgraf@fedoraproject.org> - 2013-6
- Add fedora-gnat-project-common to the requires list

* Wed Sep 04 2013 Pavel Zhukov <landgraf@fedoraproject.org> - 2013-5
- changed http://fedoraproject.org/wiki/Changes/UnversionedDocdirs

* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2013-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

* Tue Jul 16 2013  Pavel Zhukov <landgraf@fedoraproject.org> - 2013-2
- rebuild with Fedora optflags (#984721)

* Sat Jul 13 2013  Pavel Zhukov <landgraf@fedoraproject.org> - 2013-1
- New release (2013)

* Fri Jan 25 2013   Pavel Zhukov <landgraf@fedoraproject.org> - 2012-4
- Rebuild with GCC 4.8 

* Tue Dec 18 2012  Pavel Zhukov <landgraf@fedoraproject.org> - 2012-3
- Rebuild for new xmlada

* Mon Dec 17 2012  Pavel Zhukov <landgraf@fedoraproject.org> - 2012-2
- Update to gprbuild 2012

* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2011-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

* Thu Jun 21 2012 Julian Leyh <julian@vgai.de> - 2011-4
- Remove rpath from default configuration
- Make parsing of gcc version locale-independant

* Sun Mar 04 2012 Pavel Zhukov <landgraf@fedoraproject.org> - 2011-3
- Updated to 2011 (#722704)
- Add unreference patch

* Mon Feb 27 2012 Björn Persson <bjorn@rombobjörn.se> - 2011-1
- Patched to resolve the link /bin → /usr/bin.
- Removed a superfluous explicit dependency on xmlada.

* Sun Jul 17 2011 Pavel Zhukov <landgraf@fedoraproject.org> - 2010-10
- Rebuld for xmlada 2011

* Thu Mar 24 2011 Dan Horák <dan[at]danny.cz> - 2010-8
- updated the supported arch list