Blob Blame History Raw
Name:          hawtbuf
Version:       1.11
Release:       2%{?dist}
Summary:       A rich byte buffer library
License:       ASL 2.0
URL:           https://github.com/fusesource/hawtbuf/
Source0:       https://github.com/fusesource/hawtbuf/archive/%{name}-project-%{version}.tar.gz

%if (0%{?rhel} > 0) || (0%{?fedora} < 21)
BuildRequires: mvn(log4j:log4j)
BuildRequires: mvn(org.apache.maven.shared:maven-shared-components)
BuildRequires: mvn(org.fusesource:fusesource-pom)
%else
BuildRequires: mvn(log4j:log4j:1.2.17)
# B/R for maven-archiver
BuildRequires: mvn(org.apache.maven.shared:maven-shared-components:pom:)
BuildRequires: mvn(org.fusesource:fusesource-pom:pom:)
%endif
BuildRequires: mvn(commons-logging:commons-logging)
BuildRequires: mvn(org.apache.maven:maven-plugin-api)
BuildRequires: mvn(org.apache.maven:maven-project)

# test deps
BuildRequires: junit

BuildRequires: maven-local
BuildRequires: javacc-maven-plugin
BuildRequires: maven-invoker-plugin
BuildRequires: maven-plugin-bundle
BuildRequires: maven-plugin-plugin

BuildArch:     noarch

%description
This library implements a simple interface with working with
byte arrays. It is a shame that the Java SDK did not come with
a built in class that was just simply a byte[], int offset,
int length class which provided a rich interface similar to
what the String class does for char arrays. This library
fills in that void by providing a Buffer class which does provide
that rich interface.

%package proto
Summary:       A protobuf library

%description proto
HawtBuf Proto: A protobuf library.

%package protoc
Summary:       A protobuf compiler as a maven plugin

%description protoc
HawtBuf Protoc: A protobuf compiler as a maven plugin.

%package javadoc
Summary:       Javadoc for %{name}

%description javadoc
This package contains javadoc for %{name}.

%prep
%setup -q -n %{name}-%{name}-project-%{version}
%pom_remove_plugin :maven-assembly-plugin

%if (0%{?rhel} > 0) || (0%{?fedora} >= 21)
%pom_xpath_set "pom:properties/pom:log4j-version" 1.2.17
%endif

%mvn_package ":%{name}-project" %{name}

%build

%mvn_build -s

%install
%mvn_install

%files -f .mfiles-%{name}
%dir %{_javadir}/%{name}
%doc readme.md
%license license.txt notice.md

%files proto -f .mfiles-%{name}-proto
%doc %{name}-proto/readme.md
%license license.txt notice.md

%files protoc -f .mfiles-%{name}-protoc
%doc %{name}-protoc/readme.md
%license license.txt notice.md

%files javadoc -f .mfiles-javadoc
%license license.txt notice.md

%changelog
* Tue Jan 20 2015 gil cattaneo <puntogil@libero.it> 1.11-2
- introduce license macro

* Tue Jan 20 2015 gil cattaneo <puntogil@libero.it> 1.11-1
- Update to 1.11

* Wed Aug 20 2014 Darryl L. Pierce <dpierce@redhat.com> - 1.9-10
- First build for EPEL7.
- Resolves: BZ#1110028
- Added conditions so the specfile can be used across releases.

* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Fri Mar 28 2014 Michael Simacek <msimacek@redhat.com> - 1.9-8
- Use Requires: java-headless rebuild (#1067528)

* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

* Fri Jul 05 2013 gil cattaneo <puntogil@libero.it> 1.9-6
- switch to XMvn
- minor changes to adapt to current guideline

* Tue Feb 19 2013 gil cattaneo <puntogil@libero.it> 1.9-5
- disabled integration tests

* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 1.9-3
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
- Replace maven BuildRequires with maven-local

* Wed Sep 05 2012 gil cattaneo <puntogil@libero.it> 1.9-2
- removed hawtbuf-tests.jar
- performed integration test

* Tue May 22 2012 gil cattaneo <puntogil@libero.it> 1.9-1
- initial rpm