Blob Blame History Raw
Name:           ikarus
Version:        0.0.1
Release:        2%{?dist}
Summary:        An incremental optimizing compiler for R6RS Scheme

Group:          Development/Languages
License:        GPLv3
URL:            http://www.cs.indiana.edu/~aghuloum/ikarus/
Source0:        http://www.cs.indiana.edu/~aghuloum/ikarus/ikarus-%{version}.tar.gz
Patch0:         ikarus-0.0.1-bootfile.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BuildArch:      i386

BuildRequires:  gmp-devel
#Requires:       

%description
Ikarus is a free optimizing incremental native-code compiler for R6RS Scheme.

Ikarus is an optimizing compiler, so your Scheme code will run fast
without the need to port hot spots to C "for performance". With an
incremental compiler, you don't need a separate compilation step to
make your program run fast. The best part is that the compiler itself
is fast, capable of compiling thousands of lines of code per second.

Finally, Ikarus is an R6RS compiler. R6RS is the latest revision of
the Scheme standard. The preliminary release of Ikarus supports over
80% of the most important features R6RS, and later releases will bring
Ikarus closer to full R6RS conformance. R6RS libraries, scripts,
record types, condition system, exception handling, unicode strings,
bytevectors, hashtable, and enumerations are among the supported
features.


%prep
%setup -q
%patch0 -p1 -b .bootfile


%build
%configure
make %{?_smp_mflags}


%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_libdir}/ikarus
mv $RPM_BUILD_ROOT%{_bindir}/ikarus.boot $RPM_BUILD_ROOT%{_libdir}/ikarus/


%clean
rm -rf $RPM_BUILD_ROOT


%files
%defattr(-,root,root,-)
%doc COPYING GPL-3 README TODO doc/ikarus-users-guide.pdf
%{_bindir}/ikarus
%{_libdir}/ikarus


%changelog
* Sun Nov 18 2007 Michel Salim <michel.sylvan@gmail.com> 0.0.1-2
- Move boot file from _bindir to _libdir

* Mon Nov  5 2007 Michel Salim <michel.sylvan@gmail.com> 0.0.1-1
- Initial package