Blob Blame History Raw
%{expand: %%define pythonver %(python -c 'import sys;print(sys.version[0:3])')}
%define pymainver %{nil}
%define swigver 1.3.23

Summary: Support for using OpenSSL in python scripts.
Name: m2crypto
Version: 0.13
Release: 3
Source0: http://sandbox.rulemaker.net/ngps/Dist/m2crypto-%{version}.zip
Source1: http://unc.dl.sourceforge.net/sourceforge/swig/swig-%{swigver}.tar.gz
Patch0: http://sandbox.rulemaker.net/ngps/Dist/0.13p1.patch
Patch1: m2crypto-0.13-python24.patch
License: BSDish
Group: System Environment/Libraries
URL: http://sandbox.rulemaker.net/ngps/m2
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildPreReq: openssl-devel, python%{pymainver}-devel >= %{pythonver}
BuildPreReq: perl, pkgconfig, unzip
Requires: python%{pymainver}
Obsoletes: openssl-python

%description
This package allows you to call OpenSSL functions from python scripts.

%prep
%setup -q -a 1

# Create a directory to hold the local SWIG binary.
mkdir swigroot

%patch0 -p0 -b .pl1
%patch1 -p1 -b .py24

%build
CFLAGS="$RPM_OPT_FLAGS" ; export CFLAGS
if pkg-config openssl ; then
	CFLAGS="$CFLAGS `pkg-config --cflags openssl`" ; export CFLAGS
	LDFLAGS="$LDFLAGS`pkg-config --libs-only-L openssl`" ; export LDFLAGS
fi

swigroot=`pwd`/swigroot
pushd SWIG-%{swigver}
./configure \
	--prefix=${swigroot} \
	--disable-shared \
	--enable-static \
	--without-guile \
	--without-java \
	--without-ocaml \
	--without-perl5 \
	--without-php4 \
	--without-pike \
	--without-tcl
make
make install
popd

PATH=${swigroot}/bin${PATH:+:${PATH}} ; export PATH
python%{pythonver} setup.py build

%install
rm -rf $RPM_BUILD_ROOT

CFLAGS="$RPM_OPT_FLAGS" ; export CFLAGS
if pkg-config openssl ; then
	CFLAGS="$CFLAGS `pkg-config --cflags openssl`" ; export CFLAGS
	LDFLAGS="$LDFLAGS`pkg-config --libs-only-L openssl`" ; export LDFLAGS
fi

python%{pythonver} setup.py install --root=$RPM_BUILD_ROOT

%clean
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%doc BUGS CHANGES LIC* README README.Developers demo tests
%{_libdir}/python%{pythonver}/site-packages/M2Crypto

%changelog
* Tue May 31 2005 Miloslav Trmac <mitr@redhat.com> - 0.13-3
- Fix invalid Python version comparisons in M2Crypto.httpslib (#156979)
- Don't ship obsolete xmlrpclib.py.patch
- Clean up the build process a bit

* Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 0.13-2
- rebuild

* Tue Nov 23 2004 Karsten Hopp <karsten@redhat.de> 0.13-1 
- update, remove now obsolete patches

* Mon Nov 22 2004 Karsten Hopp <karsten@redhat.de> 0.09-7
- changed pythonver from 2.3 to 2.4

* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt

* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt

* Tue Feb 24 2004 Harald Hoyer <harald@redhat.com> - 0.09-5
- changed pythonver from 2.2 to 2.3
- patched setup.py to cope with include path

* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt

* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt

* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
- rebuilt

* Tue Jan 14 2003 Nalin Dahyabhai <nalin@redhat.com> 0.09-1
- Update to version 0.09
- Build using bundled copy of SWIG
- Pick up additional CFLAGS and LDFLAGS from OpenSSL's pkgconfig data, if
  there is any
- Handle const changes in new OpenSSL
- Remove unnecessary ldconfig calls in post/postun

* Thu Dec 12 2002 Elliot Lee <sopwith@redhat.com> 0.07_snap3-2
- Update to version 0.07_snap3

* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- automated rebuild

* Sun May 26 2002 Tim Powers <timp@redhat.com>
- automated rebuild

* Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.05_snap4-4
- rebuild with Python 2.2

* Wed Apr 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.05_snap4-3
- remove a stray -L at link-time which prevented linking with libssl (#59985)

* Thu Aug 23 2001 Nalin Dahyabhai <nalin@redhat.com> 0.05_snap4-2
- drop patch which isn't needed because we know swig is installed

* Mon Apr  9 2001 Nalin Dahyabhai <nalin@redhat.com> 0.05_snap4-1
- break off from openssl-python