Blob Blame History Raw
## $Id$

%{!?release_func:%global release_func() %1%{?dist}}

Name:		mimetic
Version:	0.9.3
Release:	%release_func 2
Summary:	A full featured MIME library written in C++

Group:		System Environment/Libraries
License:	GPL
URL:		http://codesink.org/mimetic_mime_library.html
Source0:	http://codesink.org/download/%name-%version.tar.gz
Patch0:		mimetic-0.9.2-noconfigh.patch
BuildRoot:	%_tmppath/%name-%version-%release-root

BuildRequires:	doxygen


%package devel
Summary:	Files for development of applications which will use %name
Group:		Development/Libraries
Requires:	%name = %version-%release


%description
mimetic is a GPL MIME library written in C++ designed to be easy to use
and integrate but yet fast and efficient. mimetic doesn't use exceptions
but it heavily uses templates so a mostly standard compliant C++ compiler
is required.


%description devel
mimetic is a GPL MIME library written in C++ designed to be easy to use
and integrate but yet fast and efficient. mimetic doesn't use exceptions
but it heavily uses templates so a mostly standard compliant C++ compiler
is required.

This package contains files for the development of applications which
will use %name.


%prep
%setup -q
%patch0 -p1 -b .noconfigh


%build
%configure --disable-static
sed -i -e 's! -shared ! -Wl,--as-needed\0!g' libtool

%__make %{?_smp_mflags}
%__make docs -C doc


%install
rm -rf $RPM_BUILD_ROOT
%__make install DESTDIR=$RPM_BUILD_ROOT

rm -f $RPM_BUILD_ROOT%_libdir/*.la


%check
%__make check


%clean
rm -rf $RPM_BUILD_ROOT


%post   -p /sbin/ldconfig
%postun -p /sbin/ldconfig


%files
%defattr(-,root,root,-)
%doc AUTHORS COPYING ChangeLog README
%_libdir/*.so.*


%files devel
%defattr(-,root,root,-)
%doc doc/html
%_libdir/*.so
%_includedir/%name


%changelog
* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.9.3-2
- Rebuild for selinux ppc32 issue.

* Thu Jun 14 2007 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.9.3-1
- updated to 0.9.3

* Sat Feb  3 2007 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.9.2-1
- updated to 0.9.2; rediffed patches
- build the library with '-Wl,--as-needed'

* Fri Sep 15 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.9.1-2
- rebuilt

* Sun Apr 16 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.9.1-1
- updated to 0.9.1
- rediffed -noconfigh patch and cover new #ifdef's
- removed -gcc41 patch

* Sun Mar 12 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.9.0-2
- fixed a missing case in the noconfigh patch

* Sun Mar 12 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.9.0-1
- updated to 0.9.0
- rediffed/updated the .noconfigh patch

* Sat Feb 18 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.8.9-4
- rebuilt for FC5

* Sun Dec 25 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.8.9-3
- fixed compilation with gcc41
- first Fedora Extras release (review #171624)

* Mon Oct 24 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.8.9-2
- workaround problems with <mimetic/config.h> which conflicts with
  local files from autoconf/automake

* Mon Oct 24 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.8.9-1
- initial release