Blob Blame History Raw
%{?nodejs_find_provides_and_requires}

%global packagename arr-flatten
%global enable_tests 1

Name:		nodejs-arr-flatten
Version:	1.0.1
Release:	1%{?dist}
Summary:	Recursively flatten an array or arrays

License:	MIT
URL:		https://github.com/jonschlinkert/arr-flatten.git
Source0:	https://registry.npmjs.org/%{packagename}/-/%{packagename}-%{version}.tgz
# The test files are not included in the npm tarball, and the 1.0.1 release has
# not yet been tagged in github, so pull from master for now
Source1:	https://raw.githubusercontent.com/jonschlinkert/arr-flatten/master/test.js


BuildArch:	noarch
%if 0%{?fedora} >= 19
ExclusiveArch: %{nodejs_arches} noarch
%else
ExclusiveArch: %{ix86} x86_64 %{arm} noarch
%endif

BuildRequires:	nodejs-packaging
%if 0%{?enable_tests}
BuildRequires:	mocha
BuildRequires:	npm(array-flatten)
%endif

%description
Recursively flatten an array or arrays. This is the fastest implementation of
array flatten.


%prep
%setup -q -n package
# setup the tests
cp -p %{SOURCE1} .

# remove unneeded executable bits
chmod -x ./*

%build
# nothing to do!

%install
mkdir -p %{buildroot}%{nodejs_sitelib}/%{packagename}
cp -pr package.json index.js \
	%{buildroot}%{nodejs_sitelib}/%{packagename}

%nodejs_symlink_deps

%check
%nodejs_symlink_deps --check
%{__nodejs} -e 'require("./")'
%if 0%{?enable_tests}
%{_bindir}/mocha -R spec
%else
%{_bindir}/echo "Tests disabled..."
%endif


%files
%{!?_licensedir:%global license %doc}
%doc *.md
%license LICENSE
%{nodejs_sitelib}/%{packagename}


%changelog
* Wed Feb  3 2016 Jared Smith <jsmith@fedoraproject.org> - 1.0.1-1
- Initial packaging