Blob Blame History Raw
%{?nodejs_find_provides_and_requires}

%global packagename modify-values

# tests missing due to missing npm(ava)
%global enable_tests 0

Name:		nodejs-modify-values
Version:	1.0.0
Release:	1%{?dist}
Summary:	Modify the values of an object

License:	MIT
URL:		https://github.com/sindresorhus/modify-values
Source0:	https://registry.npmjs.org/%{packagename}/-/%{packagename}-%{version}.tgz
Source1:	https://raw.githubusercontent.com/sindresorhus/%{packagename}/v%{version}/test.js
Source2:	https://raw.githubusercontent.com/sindresorhus/%{packagename}/v%{version}/license


ExclusiveArch:	%{nodejs_arches} noarch
BuildArch:	noarch

BuildRequires:	nodejs-packaging
%if 0%{?enable_tests}
BuildRequires:	npm(ava)
%endif

%description
Modify the values of an object


%prep
%autosetup -n package
# setup the tests and license
cp -p %{SOURCE1} .
cp -p %{SOURCE2} .

%build
# nothing to do!

%install
mkdir -p %{buildroot}%{nodejs_sitelib}/%{packagename}
cp -pr package.json index.js \
	%{buildroot}%{nodejs_sitelib}/%{packagename}

%nodejs_symlink_deps

%check
%nodejs_symlink_deps --check
%{__nodejs} -e 'require("./")'
%if 0%{?enable_tests}
%{_bindir}/ava
%else
%{_bindir}/echo -e "\e[101m -=#=- Tests disabled -=#=- \e[0m"
%endif

%files
%doc readme.md
%license license
%{nodejs_sitelib}/%{packagename}

%changelog
* Sat May  6 2017 Jared Smith <jsmith@fedoraproject.org> - 1.0.0-1
- Initial packaging