Blob Blame History Raw
%{?nodejs_find_provides_and_requires}

%global packagename read-json-sync
%global enable_tests 1
%global upstream_version 2.0.0-1

Name:		nodejs-read-json-sync
Version:	2.0.0.1
Release:	3%{?dist}
Summary:	Read and parse a JSON file synchronously

License:	CC0
URL:		https://github.com/shinnn/read-json-sync
Source0:	https://registry.npmjs.org/%{packagename}/-/%{packagename}-%{upstream_version}.tgz
# The test files are not included in the npm tarball.
# Source{1-9} are generated by running Source10, which pulls from the upstream
# version control repository.
Source1:	tests-%{version}.tar.bz2
Source10:	dl-tests.sh


BuildArch:	noarch
%if 0%{?fedora} >= 19
ExclusiveArch: %{nodejs_arches} noarch
%else
ExclusiveArch: %{ix86} x86_64 %{arm} noarch
%endif

BuildRequires:	nodejs-packaging
BuildRequires:	npm(graceful-fs)

%if 0%{?enable_tests}
BuildRequires:	npm(tap-spec)
BuildRequires:	npm(tape)
%endif

%description
Read and parse a JSON file synchronously


%prep
%autosetup -n package
# setup the tests
%autosetup -T -D -a 1 -n package

%build
# nothing to do

%install
mkdir -p %{buildroot}%{nodejs_sitelib}/%{packagename}
cp -pr package.json *.js \
	%{buildroot}%{nodejs_sitelib}/%{packagename}

%nodejs_symlink_deps

%check
%nodejs_symlink_deps --check
%{__nodejs} -e 'require("./")'
%if 0%{?enable_tests}
%__nodejs test/test.js | tap-spec
%else
%{_bindir}/echo -e "\e[101m -=#=- Tests disabled -=#=- \e[0m"
%endif

%files
%{!?_licensedir:%global license %doc}
%doc *.md
%{nodejs_sitelib}/%{packagename}

%changelog
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Tue Sep 19 2017 Jared Smith <jsmith@fedoraproject.org> - 2.0.0-1
- Update to upstream 2.0.0-1 release

* Fri Jul 29 2016 Jared Smith <jsmith@fedoraproject.org> - 1.1.1
- Initial packaging