Blob Blame History Raw
Name:           perl-App-SVN-Bisect
Version:        1.0
Release:        1%{?dist}
Summary:        Binary search through svn revisions
License:        Artistic 2.0
Group:          Development/Libraries
URL:            http://search.cpan.org/dist/App-SVN-Bisect/
Source0:        http://www.cpan.org/modules/by-module/App/INFINOID/App-SVN-Bisect-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch:      noarch
BuildRequires:  perl(IO::All)
BuildRequires:  perl(Module::Build)
BuildRequires:  perl(Test::Exception)
BuildRequires:  perl(Test::Output)
BuildRequires:  perl(Test::Pod)
BuildRequires:  perl(Test::Pod::Coverage)
BuildRequires:  perl(YAML::Syck)
BuildRequires:  subversion
Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Requires:       subversion


%description
This module implements the backend of the "svn-bisect" command line tool.
See the POD documentation of that tool, for usage details.


%package -n svn-bisect
License: Artistic 2.0
Group: Development/Libraries
Summary: Binary search through svn revisions
Requires: %{name} = 0:%{version}-%{release} 


%description -n svn-bisect
This is a command-line tool inspired by "git-bisect", which allows you to
perform binary searches among the revisions of a subversion project.


%prep
%setup -q -n App-SVN-Bisect-%{version}


%build
%{__perl} Build.PL installdirs=vendor
./Build


%install
rm -rf $RPM_BUILD_ROOT

./Build install destdir=$RPM_BUILD_ROOT create_packlist=0
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;

%{_fixperms} $RPM_BUILD_ROOT/*


%check
./Build test


%clean
rm -rf $RPM_BUILD_ROOT


%files
%defattr(-,root,root,-)
%doc Changes LICENSE README TODO
%{perl_vendorlib}/*
%{_mandir}/man3/*


%files -n svn-bisect
%defattr(-,root,root,-)
%doc Changes LICENSE README TODO
%{_bindir}/svn-bisect
%{_mandir}/man1/svn-bisect.1*


%changelog
* Fri Jun 04 2010 Xavier Bachelot <xavier@bachelot.org> 1.0-1
- Specfile autogenerated by cpanspec 1.78.
- Clean up and adapt spec.