Blob Blame History Raw
Name:           perl-DBIx-XHTML_Table
Version:        1.47
Release:        2%{?dist}
Summary:        SQL query result set to XHTML table
# MIT: lib/DBIx/XHTML_Table.pm
# Artistic 2.0: metadata
License:        MIT and Artistic 2.0
URL:            http://search.cpan.org/dist/DBIx-XHTML_Table/
Source0:        http://www.cpan.org/authors/id/J/JE/JEFFA/DBIx-XHTML_Table-%{version}.tar.gz
BuildArch:      noarch
BuildRequires:  make
BuildRequires:  perl
BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.76
BuildRequires:  perl(strict)
BuildRequires:  perl(warnings)
# Run-time
BuildRequires:  perl(Carp)
BuildRequires:  perl(DBI)
BuildRequires:  perl(vars)
# Tests
BuildRequires:  perl(Data::Dumper)
BuildRequires:  perl(DBD::CSV)
BuildRequires:  perl(FindBin)
BuildRequires:  perl(HTML::TableExtract)
BuildRequires:  perl(Test::More)
BuildRequires:  perl(utf8)
Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))

%description
DBIx::XHTML_Table is a DBI extension that creates an XHTML table from a
database query result set. It was created to fill the gap between fetching
rows from a database and transforming them into a web browser renderable
table. DBIx::XHTML_Table is intended for programmers who want the
responsibility of presenting (decorating) data, easily. This module is
meant to be used in situations where the concern for presentation and logic
separation is overkill. Providing logic or editable data is beyond the
scope of this module, but it is capable of doing such.

%prep
%setup -q -n DBIx-XHTML_Table-%{version}

%build
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1
make %{?_smp_mflags}

%install
make pure_install DESTDIR=$RPM_BUILD_ROOT
%{_fixperms} $RPM_BUILD_ROOT/*

%check
make test

%files
%doc Changes readme.md
%{perl_vendorlib}/*
%{_mandir}/man3/*

%changelog
* Fri Feb 12 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.47-2
- Update license

* Thu Feb 11 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.47-1
- Initial release