Blob Blame History Raw
Name:           perl-Parse-CPAN-Packages
Version:        2.31
Release:        1%{?dist}
Summary:        Parse 02packages.details.txt.gz
License:        GPL+ or Artistic
Group:          Development/Libraries
URL:            http://search.cpan.org/dist/Parse-CPAN-Packages/
Source0:        http://www.cpan.org/authors/id/L/LB/LBROCARD/Parse-CPAN-Packages-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch:      noarch
BuildRequires:  perl(Compress::Zlib)
BuildRequires:  perl(CPAN::DistnameInfo)
BuildRequires:  perl(ExtUtils::MakeMaker)
BuildRequires:  perl(Moose)
BuildRequires:  perl(Test::More)
BuildRequires:  perl(Test::Pod)
BuildRequires:  perl(Test::Pod::Coverage)
BuildRequires:  perl(version)
Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))

%description
The Comprehensive Perl Archive Network (CPAN) is a very useful collection
of Perl code. It has several indices of the files that it hosts, including
a file named "02packages.details.txt.gz" in the "modules" directory. This
file contains lots of useful information and this module provides a simple
interface to the data contained within.

%prep
%setup -q -n Parse-CPAN-Packages-%{version}

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}

%install
rm -rf $RPM_BUILD_ROOT

make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT

find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;

%{_fixperms} $RPM_BUILD_ROOT/*

%check
make test

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc CHANGES README
%{perl_vendorlib}/*
%{_mandir}/man3/*

%changelog
* Wed May 13 2009 Steven Pritchard <steve@kspei.com> 2.31-1
- Update to 2.31.

* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.30-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

* Mon Feb 02 2009 Steven Pritchard <steve@kspei.com> 2.30-1
- Update to 2.30.
- BR Compress::Zlib, Moose, Test::Pod, and Test::Pod::Coverage.
- Drop BR Class::Accessor::Fast, IO::Zlib, and Sort::Versions.

* Thu Dec 11 2008 Steven Pritchard <steve@kspei.com> 2.29-1
- Update to 2.29.

* Fri Feb  8 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.27-2
- rebuild for new perl

* Sat Jan 12 2008 Steven Pritchard <steve@kspei.com> 2.27-1
- Update to 2.27.
- Switch from building with Build.PL to Makefile.PL.

* Sat Dec 29 2007 Ralf Cors├ępius <rc040203@freenet.de> - 2.26-5
- Adjust License-tag.
- Add BR: perl(Test::More) (BZ 419631).

* Wed Apr 18 2007 Steven Pritchard <steve@kspei.com> 2.26-4
- Use fixperms macro instead of our own chmod incantation.

* Sat Sep 16 2006 Steven Pritchard <steve@kspei.com> 2.26-3
- Fix find option order.

* Sat Jul 01 2006 Steven Pritchard <steve@kspei.com> 2.26-2
- BR version.pm.

* Sat Jul 01 2006 Steven Pritchard <steve@kspei.com> 2.26-1
- Update to 2.26.
- Various cleanups.

* Wed Feb 01 2006 Steven Pritchard <steve@kspei.com> 2.25-2
- Drop explicit Requires (except perl(Class::Accessor::Fast), which isn't
  picked up automatically).

* Mon Sep 19 2005 Steven Pritchard <steve@kspei.com> 2.25-1
- Specfile autogenerated.