Blob Blame History Raw
Name:           perl-Test-Simple
Summary:        Basic utilities for writing tests
Version:        0.94
Release:        1%{?dist}
License:        GPL+ or Artistic
Group:          Development/Libraries
Source0:        http://search.cpan.org/CPAN/authors/id/M/MS/MSCHWERN/Test-Simple-%{version}.tar.gz 
URL:            http://search.cpan.org/dist/Test-Simple
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
BuildArch:      noarch

BuildRequires:  perl(ExtUtils::MakeMaker)
BuildRequires:  perl(Test::Harness) >= 2.03
Requires:       perl(Test::Harness) >= 2.03

# note this is right out of perl.spec
Requires:       perl-devel

## testing
#Requires:       perl-tests
#Requires:       /usr/bin/prove

%{?perl_default_filter}
%{?perl_default_subpackage_tests}

%description
This package provides the bulk of the core testing facilities.  For more
information, see perldoc for Test::Simple, Test::More, etc.

This package is the CPAN component of the dual-lifed core package Test-Simple.

%prep
%setup -q -n Test-Simple-%{version}

%build
%{__perl} Makefile.PL INSTALLDIRS=perl
make %{?_smp_mflags}

%install
rm -rf %{buildroot}

make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'

%{_fixperms} %{buildroot}/*

%check
make test

#cd %{_libexecdir}/perl5-tests/perl-tests/
#prove -I %{buildroot}/blib -r t/

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root,-)
%doc Changes README examples/
%{perl_privlib}/*
%{_mandir}/man3/*.3*

%changelog
* Tue Mar 16 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.94-1
- specfile by Fedora::App::MaintainerTools 0.006