Blob Blame History Raw
Name:           perl-Tree
Version:        1.08
Release:        1%{?dist}
Summary:        Tree data structure
# lib/Tree/Binary2.pm:  GPL+ or Artistic
# lib/Tree/Fast.pm:     GPL+ or Artistic
# lib/Tree.pm:          GPL+ or Artistic
# LICENSE:              GPL+ or Artistic
License:        GPL+ or Artistic
Group:          Development/Libraries
URL:            http://search.cpan.org/dist/Tree/
Source0:        http://www.cpan.org/authors/id/R/RS/RSAVAGE/Tree-%{version}.tgz
BuildArch:      noarch
BuildRequires:  coreutils
BuildRequires:  findutils
BuildRequires:  make
BuildRequires:  perl
BuildRequires:  perl-generators
BuildRequires:  perl(ExtUtils::MakeMaker)
BuildRequires:  perl(strict)
BuildRequires:  perl(warnings)
# Run-time:
BuildRequires:  perl(base)
BuildRequires:  perl(constant)
BuildRequires:  perl(overload)
BuildRequires:  perl(Scalar::Util) >= 1.1
# Tests:
BuildRequires:  perl(Data::Dumper) >= 2.136
BuildRequires:  perl(Exporter) >= 5.66
BuildRequires:  perl(lib)
BuildRequires:  perl(Test::Deep) >= 0.088
BuildRequires:  perl(Test::Exception) >= 0.15
BuildRequires:  perl(Test::More) >= 1.001014
BuildRequires:  perl(Test::Warn) >= 0.08
# Optional tests:
BuildRequires:  perl(Test::Memory::Cycle) >= 1.02
Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
Requires:       perl(Scalar::Util) >= 1.1

# Filter under-specified dependencies
%global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Scalar::Util\\)$

%description
This implements a full-featured N-ary tree representation with configurable
error-handling and a simple events system that allows for transparent
persistence to a variety of data stores.

%prep
%setup -q -n Tree-%{version}
chmod 0644 lib/Tree.pm

%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}

%install
make pure_install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -type f -name .packlist -delete
%{_fixperms} $RPM_BUILD_ROOT/*

%check
make test

%files
%license LICENSE
# README not useful
%doc Changes scripts
%{perl_vendorlib}/*
%{_mandir}/man3/*

%changelog
* Thu May 05 2016 Petr Pisar <ppisar@redhat.com> - 1.08-1
- 1.08 bump
- License changed to (GPL+ or Artistic)

* Fri Apr 15 2016 Petr Pisar <ppisar@redhat.com> 1.07-1
- Specfile autogenerated by cpanspec 1.78.