Blob Blame History Raw
%define pyver %(python -c 'import sys ; print sys.version[:3]')

Summary: Python bindings for the cairo library
Name: pycairo
Version: 1.0.2 
Release: 2
License: LGPL
Group: Development/Languages
URL: http://cairographics.org/
Source0: %{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: python
BuildRequires: cairo-devel 
BuildRequires: python-devel
BuildRequires: pkgconfig
Requires: cairo
%description
Python bindings for the cairo library

%package devel
Summary: Libraries and headers for pycairo
Group: Development/Libraries
Requires: %name = %{version}-%{release}
Requires: cairo-devel python-devel

%description devel

Headers for pycairo 

%prep
%setup -q

%configure

%build
make

%install
rm -rf $RPM_BUILD_ROOT

%makeinstall
find $RPM_BUILD_ROOT -name '*.la' |xargs rm 

%clean
rm -rf $RPM_BUILD_ROOT


%files
%defattr(-,root,root,-)
%doc
%{_libdir}/python%{pyver}/site-packages/cairo/

%files devel
%defattr(-,root,root,-)

%{_libdir}/pkgconfig/pycairo.pc
%dir %{_includedir}/pycairo
%{_includedir}/pycairo/pycairo.h

%changelog
* Mon Jun 05 2006 John (J5) Palmieri <johnp@redhat.com> - 1.0.2-2
- add pkgconfig BR

* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-1.2.1
- bump again for double-long bug on ppc(64)

* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-1.2
- rebuilt for new gcc4.1 snapshot and glibc changes

* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt

* Wed Oct 26 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.2-1
- Updated to latest and push into rawhide

* Fri Dec 10 2004 Kristian Høgsberg <krh@redhat.com> - 0.1.3-1
- Add python-devel build requires.

* Wed Nov 24 2004  <jrb@redhat.com> - 
- Initial build.