Blob Blame History Raw

%bcond_without tests

%global _description %{expand:
PyPlane is a free software for phase plane analysis of second order dynamical
systems written in PYTHON and PyQT5. Comparable to MATLAB's pplane.}

%global forgeurl https://github.com/TUD-RST/pyplane
%global commit e8b9b8d7bfb75aa9289c22f9ff180c1a17fb7868
%forgemeta

Name:           python-pyplane
Version:        1.2.0
Release:        0.1
Summary:        Phase plane analysis of nonlinear systems

# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
License:        GPLv3
URL:            %{forgeurl}
Source0:        %{forgesource}

BuildArch:      noarch


%description %_description

%package -n python3-pyplane
Summary:        %{summary}
BuildRequires:  python3-devel python3-pytest
BuildRequires:  python3-pytest
BuildRequires:  matplotlib

%description -n python3-pyplane %_description

%package doc
Summary:        Documentation for %{name}
BuildRequires:  make matplotlib
BuildRequires:  %{py3_dist sphinx}

%description doc
This package provides documentation for %{name}.


%prep
%forgesetup

%generate_buildrequires
%pyproject_buildrequires

# can also use something like this
# %%pyproject_buildrequires -r %%{?with_tests:-x test}


%build
%pyproject_wheel

# Sometimes needed so sphinx can import the module
#PYTHONPATH=".:.." make -C doc SPHINXBUILD=sphinx-build-3 html


#rm -rf doc/_build/html/{.doctrees,.buildinfo} -vf

%install
%pyproject_install
%pyproject_save_files pyplane

%check
export PYTHONPATH='%{buildroot}%{python3_sitelib}:%{buildroot}%{python3_sitelib}/pyplane'
%if %{with tests}
%{pytest}
%{tox}
%endif

# LICENSE/COPYING are included in the dist-info, so we do not need to
# explicitly list them again
%files -n python3-pyplane -f %{pyproject_files}
%doc README.rst

%files doc
%license COPYING
%doc doc/_build/html

%changelog
%autochangelog