Blob Blame History Raw
# Created by pyp2rpm-3.1.2
%global pypi_name QtAwesome
%global simple_name qtawesome

Name:		python-%{pypi_name}
Version:	0.3.3
Release:	4%{?dist}
Summary:	FontAwesome icons in PyQt and PySide applications
License:	MIT and OFL
URL:		https://github.com/spyder-ide/%{simple_name}
Source0:	https://github.com/spyder-ide/%{simple_name}/archive/v%{version}/%{simple_name}-%{version}.tar.gz
BuildArch:	noarch
 
BuildRequires:	python-setuptools
BuildRequires:	python2-devel
 
BuildRequires:	python3-setuptools
BuildRequires:	python3-devel

#provides font files
#./qtawesome/fonts/fontawesome-webfont.ttf
Provides:	bundled(elusiveicons-fonts) = 001.000
#./qtawesome/fonts/elusiveicons-webfont.ttf
Provides:	bundled(fontawesome-fonts) = 4.4.1

%description
QtAwesome enables iconic fonts such as Font Awesome and Elusive.

It is a port to Python - PyQt / PySide of the QtAwesome C++ library by 
Rick Blommers.

%package -n     python2-%{pypi_name}
Summary:	FontAwesome icons in PyQt and PySide applications
%{?python_provide:%python_provide python2-%{pypi_name}}
 
Requires:	python-qtpy
Requires:	python-six

%description -n python2-%{pypi_name}

QtAwesome enables iconic fonts such as Font Awesome and Elusive.

It is a port to Python - PyQt / PySide of the QtAwesome C++ library by 
Rick Blommers.

%package -n     python3-%{pypi_name}
Summary:	FontAwesome icons in PyQt and PySide applications
%{?python_provide:%python_provide python3-%{pypi_name}}
 
Requires:	python3-qtpy
Requires:	python3-six

%description -n python3-%{pypi_name}

QtAwesome enables iconic fonts such as Font Awesome and Elusive.

It is a port to Python - PyQt / PySide of the QtAwesome C++ library by 
Rick Blommers.

%prep
%autosetup -n %{simple_name}-%{version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%py2_build
%py3_build

%install
# Must do the subpackages' install first because the scripts in /usr/bin are
# overwritten with every setup.py install.
%py3_install

%py2_install


%files -n python2-%{pypi_name} 
%license LICENSE
%doc README.md
%{python2_sitelib}/qtawesome
%{python2_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info

%files -n python3-%{pypi_name} 
%license LICENSE
%doc README.md
%{python3_sitelib}/qtawesome
%{python3_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info

%changelog
* Thu Sep 29 2016 Mukundan Ragavan <nonamedotc@gmail.com> - 0.3.3-4
- Added license tag
- Added doc file 
- Added provides

* Thu Sep 29 2016 Mukundan Ragavan <nonamedotc@gmail.com> - 0.3.3-3
- Fix source url

* Thu Sep 29 2016 Mukundan Ragavan <nonamedotc@gmail.com> - 0.3.3-2
- Fix license file installation

* Thu Aug 11 2016 Mukundan Ragavan <nonamedotc@gmail.com> - 0.3.3-1
- Initial package.