Blob Blame History Raw
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}

Name:		python-application
Version:	1.1.5
Release:	1%{?dist}
Summary:	Basic building blocks for python applications
Group:		Development/Languages
License:	LGPLv2+
URL:		http://pypi.python.org/pypi/python-application
Source0:	http://pypi.python.org/packages/source/p/%{name}/%{name}-%{version}.tar.gz
BuildRoot:	%(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires:	python-devel
BuildRequires:	python-setuptools-devel
BuildArch:	noarch


%description
This package is a collection of modules that are useful when building python
applications. Their purpose is to eliminate the need to divert resources
into implementing the small tasks that every application needs to do in
order to run successfully and focus instead on the application logic itself.

%prep
%setup -q
chmod 0644 examples/*.py

%build
%{__python} -c 'import setuptools; execfile("setup.py")' build



%install
rm -rf $RPM_BUILD_ROOT
%{__python} -c 'import setuptools; execfile("setup.py")' install --skip-build --root $RPM_BUILD_ROOT


%clean
rm -rf $RPM_BUILD_ROOT


%files
%defattr(-,root,root,-)
%doc LICENSE NEWS PKG-INFO README examples
%{python_sitelib}/application/
%{python_sitelib}/python_application-%{version}-*.egg-info/


%changelog
* Wed Sep  9 2009 Peter Lemenkov <lemenkov@gmail.com> 1.1.5-1
- Ver. 1.1.5

* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

* Fri Jul 10 2009 Peter Lemenkov <lemenkov@gmail.com> 1.1.2-1
- Ver. 1.1.2

* Mon Jun  1 2009 Peter Lemenkov <lemenkov@gmail.com> 1.1.1-2
- Added missing BR python-setuptools-devel

* Fri May 29 2009 Peter Lemenkov <lemenkov@gmail.com> 1.1.1-1
- Initial build