Blob Blame History Raw
%global sqlite_version 3.7.11
%global uprel 1
%global pkg_version %{sqlite_version}-r%{uprel}

%filter_provides_in %{python_sitearch}/.*\.so$ 
%filter_setup

Name:               python-apsw
Version:            %{sqlite_version}.r%{uprel}
Release:            7%{?dist}
Summary:            Another Python SQLite Wrapper
Source:             http://apsw.googlecode.com/files/apsw-%{pkg_version}.zip
URL:                http://code.google.com/p/apsw/
Group:              Development/Libraries
License:            zlib

BuildRequires:      sqlite-devel >= %{sqlite_version}
BuildRequires:      python2-devel
Requires:           sqlite >= %{sqlite_version}


%description
APSW is a Python wrapper for the SQLite embedded relational database
engine. In contrast to other wrappers such as pysqlite it focuses on
being a minimal layer over SQLite attempting just to translate the
complete SQLite API into Python.

%prep
%setup -q -n "apsw-%{pkg_version}"
rm doc/.buildinfo

%build
CFLAGS="%{optflags} -fno-strict-aliasing" \
%__python ./setup.py build

%install
%__python ./setup.py install \
    --prefix="%{_prefix}" \
    --root="%{buildroot}"

%files
%doc doc/*
%{python_sitearch}/*


%changelog
* Tue Oct 30 2012 Marcel Wysocki <maci@satgnu.net> 3.7.11.r1-7
- use python2-devel BR instead of python-devel

* Mon Oct 29 2012 Marcel Wysocki <maci@satgnu.net> 3.7.11.r1-6
- removed -doc package, not really needed

* Sun Oct 28 2012 Marcel Wysocki <maci@satgnu.net> 3.7.11.r1-5
- fixed changelog rpmlint error

* Sat Oct 27 2012 Marcel Wysocki <maci@satgnu.net> 3.7.11.r1-4
- use global instead of define macro
- filter private-shared-object-provides 
- removed python from requires

* Tue Oct 23 2012 Marcel Wysocki <maci@satgnu.net> 3.7.11.r1-3
- don't use rm macro
- remove doc/.buildinfo
- add missing dependencies

* Fri Oct 05 2012 Marcel Wysocki <maci@satgnu.net> 3.7.11.r1-2
- add missing builddep

* Thu Oct 04 2012 Marcel Wysocki <maci@satgnu.net> 3.7.11.r1-1
- fedora port
- update to 3.7.11-r1

* Wed Nov 30 2011 Dmitry Mikhirev <dmikhirev@mandriva.org> 3.7.7.1.r1-1
+ Revision: 735584
- imported package python-apsw