Blob Blame History Raw
Name:           python-argon2-cffi
Version:        21.1.0
Release:        %autorelease
Summary:        The secure Argon2 password hashing algorithm

License:        MIT
URL:            https://argon2-cffi.readthedocs.io/
Source0:        %{pypi_source argon2-cffi}

BuildRequires:  gcc
BuildRequires:  python3-devel >= 3.5

BuildRequires:  python3dist(cffi)
BuildRequires:  python3dist(hypothesis)
BuildRequires:  python3dist(pytest)
BuildRequires:  python3dist(setuptools)
BuildRequires:  python3dist(six)
BuildRequires:  python3dist(wheel)

BuildRequires:  pkgconfig(libargon2)

%global _description %{expand:
CFFI-based Argon2 Bindings for Python.}

%description %_description


%package -n     python3-argon2-cffi
Summary:        %{summary}
%{?python_provide:%python_provide python3-argon2-cffi}

%description -n python3-argon2-cffi %_description


%prep
%autosetup -n argon2-cffi-%{version}
# using system libargon
rm -r extras/libargon2


%build
export ARGON2_CFFI_USE_SYSTEM=1
%py3_build

%install
%py3_install


%check
%pytest


%files -n python3-argon2-cffi
%license LICENSE
%doc README.rst
%{python3_sitearch}/argon2/
%{python3_sitearch}/argon2_cffi-%{version}-py%{python3_version}.egg-info/


%changelog
%autochangelog