Blob Blame History Raw
%global         srcname     azure-mgmt-batchai

Name:           python-%{srcname}
Version:        2.0.0
Release:        4%{?dist}
Summary:        Microsoft Azure Batch AI Management Client Library for Python
License:        MIT
URL:            https://pypi.org/project/%{srcname}/
Source0:        %{pypi_source %{srcname} %{version} zip}
Patch0:         remove-custom-wheel-generator.patch

BuildArch:      noarch

Epoch:          1

Obsoletes:      python-azure-sdk < 5.0.1

BuildRequires:  python%{python3_pkgversion}-devel
BuildRequires:  pyproject-rpm-macros


%global _description %{expand:
Microsoft Azure Batch AI Management Client Library for Python}

%description %{_description}


%package -n python%{python3_pkgversion}-%{srcname}
Summary:        %{summary}

%description -n python%{python3_pkgversion}-%{srcname} %{_description}


%prep
%autosetup -p0 -n %{srcname}-%{version}

# Remove the customized wheel builder included by Microsoft that adds
# azure-mgmt-nspkg to the requirements.
rm -f azure_bdist_wheel.py

%generate_buildrequires
%pyproject_buildrequires -r


%build
%pyproject_wheel


%install
%pyproject_install

# PEP 420 allows implicit namespace packaging without additional __init__.py
# files. Remove unneccessary __init__.py that conflicts with other packages.
rm -rf %{buildroot}%{python3_sitelib}/azure/{__init__.py,__pycache__}
rm -rf %{buildroot}%{python3_sitelib}/azure/mgmt/{__init__.py,__pycache__}


%files -n python3-%{srcname}
%doc README.rst HISTORY.rst
%{python3_sitelib}/azure/mgmt/batchai
%{python3_sitelib}/azure_mgmt_batchai-%{version}.dist-info


%changelog
* Fri Jul 23 2021 Major Hayden <major@mhtx.net> - 1:2.0.0-4
- Add epoch number to 2.0.0 downgrade

* Wed Jul 14 2021 Major Hayden <major@mhtx.net> - 2.0.0-3
- Remove unneccessary __init__.py files to avoid file conflicts.

* Wed Jul 07 2021 Major Hayden <major@mhtx.net> - 2.0.0-2
- Removed customized wheel builder from package to avoid -nspkg requirement.

* Tue Jun 01 2021 Major Hayden <major@mhtx.net> - 2.0.0-1
- First package.