Blob Blame History Raw
# Created by pyp2rpm-1.1.2
%global pypi_name colour-runner
%global with_python3 1

Name:           python-%{pypi_name}
Version:        0.0.4
Release:        2%{?dist}
Summary:        Colour formatting for unittest tests

License:        MIT
URL:            https://github.com/meshy/colour-runner
Source0:        https://pypi.python.org/packages/source/c/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
Source1:        LICENSE
BuildArch:      noarch
 
BuildRequires:  python2-devel
BuildRequires:  python-setuptools
 
%if %{?with_python3}
BuildRequires:  python3-devel
BuildRequires:  python3-setuptools
%endif # if with_python3
 
Requires:       python-blessings
Requires:       python-pygments

%description
Colour formatting for unittest test output.

%if 0%{?with_python3}
%package -n     python3-%{pypi_name}
Summary:        Colour formatting for unittest tests
 
Requires:       python3-blessings
Requires:       python3-pygments

%description -n python3-%{pypi_name}
Colour formatting for unittest test output.
%endif # with_python3


%prep
%setup -q -n %{pypi_name}-%{version}
cp %{SOURCE1} .
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info


%if 0%{?with_python3}
rm -rf %{py3dir}
cp -a . %{py3dir}
find %{py3dir} -name '*.py' | xargs sed -i '1s|^#!python|#!%{__python3}|'

%endif # with_python3


%build
%{__python2} setup.py build

%if 0%{?with_python3}
pushd %{py3dir}
%{__python3} setup.py build
popd
%endif # with_python3


%install
# Must do the subpackages' install first because the scripts in /usr/bin are
# overwritten with every setup.py install (and we want the python2 version
# to be the default for now).
%if 0%{?with_python3}
pushd %{py3dir}
%{__python3} setup.py install --skip-build --root %{buildroot}
popd
%endif # with_python3

%{__python2} setup.py install --skip-build --root %{buildroot}



%files
%license LICENSE
%{python2_sitelib}/colour_runner
%{python2_sitelib}/colour_runner-%{version}-py?.?.egg-info
%if 0%{?with_python3}
%license LICENSE
%files -n python3-%{pypi_name}
%{python3_sitelib}/colour_runner
%{python3_sitelib}/colour_runner-%{version}-py?.?.egg-info
%endif # with_python3


%changelog
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

* Mon Mar 16 2015 Robert Kuska <rkuska@redhat.com> - 0.0.4-1
- Initial package.