Blob Blame History Raw
# Created by pyp2rpm-0.5.1
%global pypi_name fuzzywuzzy

Name:           python-%{pypi_name}
Version:        0.1
Release:        5%{?dist}
Summary:        Fuzzy string matching in Python

License:        MIT
URL:            https://github.com/seatgeek/fuzzywuzzy/
Source0:        http://pypi.python.org/packages/source/f/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
# Already asked upstream to include COPYING in the source tar:
# https://github.com/seatgeek/fuzzywuzzy/issues/10
Source1:        https://raw.github.com/seatgeek/fuzzywuzzy/master/LICENSE.txt
BuildArch:      noarch
 
BuildRequires:  python2-devel
BuildRequires:  python-nose


%description
Fuzzy string matching like a boss.


%prep
%setup -q -n %{pypi_name}-%{version}
cp %{SOURCE1} .
# these scripts shouldn't be executable
sed -i '1d' %{pypi_name}/fuzz.py
sed -i '1d' %{pypi_name}/process.py
# remove unneeded empty file
rm %{pypi_name}/benchmarks.py


%build
%{__python} setup.py build


%install
%{__python} setup.py install --skip-build --root %{buildroot}


%check
nosetests


%files
%doc LICENSE.txt
%{python_sitelib}/%{pypi_name}
%{python_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info

%changelog
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild

* Tue Jun 26 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 0.1-2
- python-devel should be python2-devel
- URL now points to the real homepage of the project

* Fri Jun 22 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 0.1-1
- Initial package.