Blob Blame History Raw
%if 0%{?fedora}
%global with_python3 1
%endif
%global pypi_name kafka-python

Name:             python-kafka
Version:          1.4.3
Release:          1%{?dist}
Summary:          Pure Python client for Apache Kafka

License:          ASL 2.0
URL:              https://github.com/dpkp/%{pypi_name}
Source0:          https://pypi.io/packages/source/k/%{pypi_name}/%{pypi_name}-%{version}.tar.gz

BuildArch:        noarch
BuildRequires:    python2-setuptools
BuildRequires:    python2-devel
BuildRequires:    python2-pbr
BuildRequires:    python2-sphinx

%global _description\
This module provides low-level protocol support for Apache Kafka as well as high-level\
consumer and producer classes. Request batching is supported by the protocol as well as\
broker-aware request routing. Gzip and Snappy compression is also supported for message\
sets.

%description %_description

%package -n python2-kafka
Summary: %summary
Requires: python2-six
%{?python_provide:%python_provide python2-kafka}

%description -n python2-kafka %_description

%if 0%{?with_python3}
%package -n python3-kafka
Summary:          Pure Python client for Apache Kafka
BuildRequires:    python3-setuptools
BuildRequires:    python3-devel
BuildRequires:    python3-sphinx

%description -n python3-kafka
This module provides low-level protocol support for Apache Kafka as well as high-level
consumer and producer classes. Request batching is supported by the protocol as well as
broker-aware request routing. Gzip and Snappy compression is also supported for message
sets.

%endif # with_python3

%prep
%autosetup -n %{pypi_name}-%{version}

%build
%py2_build

%if 0%{?with_python3}
%py3_build
%endif # with_python3


%install
%if 0%{?with_python3}
%py3_install
%endif # with_python3

%py2_install


%files -n python2-kafka
%doc README.rst
%{python2_sitelib}/kafka
%{python2_sitelib}/*.egg-info

%if 0%{?with_python3}
%files -n python3-kafka
%{python3_sitelib}/kafka
%{python3_sitelib}/kafka*.egg-info
%doc README.rst
%endif # with_python3


%changelog
* Thu Jul 19 2018 Matthias Runge <mrunge@redhat.com> - 1.4.3-1
- rebuild for python 3.7
- modernize spec file
- update to 1.4.3 (rhbz#1306795)

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 1.3.1-7
- Rebuilt for Python 3.7

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Thu Jan 25 2018 Iryna Shcherbina <ishcherb@redhat.com> - 1.3.1-5
- Update Python 2 dependency declarations to new packaging standards
  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)

* Sat Aug 19 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.3.1-4
- Python 2 binary package renamed to python2-kafka
  See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3

* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild

* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild

* Thu Jan 26 2017 Haïkel Guémar <hguemar@fedoraproject.org> - 1.3.1-1
- Upstream 1.3.1

* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.9.4-4
- Rebuild for Python 3.6

* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4-3
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages

* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

* Tue Nov 17 2015 Pradeep Kilambi <pkilambi@redhat.com> 0.9.4
- Initial package based on python-kafka.