Blob Blame History Raw
%global srcname libnacl
%global sum Python bindings for libsodium based on ctypes

Name:           python-%{srcname}
Version:        1.5.0
Release:        1%{?dist}
Summary:        %{sum}

License:        ASL 2.0
URL:            https://libnacl.readthedocs.org/
Source0:        https://files.pythonhosted.org/packages/source/l/%{srcname}/%{srcname}-%{version}.tar.gz

BuildArch:      noarch
BuildRequires:  python2-devel python3-devel
BuildRequires:  libsodium

%description
python-libnacl is used to gain direct access to the functions exposed by
Daniel J. Bernstein’s nacl library via libsodium. It has been constructed
to maintain extensive documentation on how to use nacl as well as being
completely portable.


%package -n python2-%{srcname}
Summary:        %{sum}
Requires:       libsodium
%{?python_provide:%python_provide python2-%{srcname}}

%description -n python2-%{srcname}
python-libnacl is used to gain direct access to the functions exposed by
Daniel J. Bernstein’s nacl library via libsodium. It has been constructed
to maintain extensive documentation on how to use nacl as well as being
completely portable.


%package -n python3-%{srcname}
Summary:        %{sum}
Requires:       libsodium
%{?python_provide:%python_provide python3-%{srcname}}

%description -n python3-%{srcname}
python-libnacl is used to gain direct access to the functions exposed by
Daniel J. Bernstein’s nacl library via libsodium. It has been constructed
to maintain extensive documentation on how to use nacl as well as being
completely portable.


%prep
%autosetup -n %{srcname}-%{version}
rm -rf %{name}.egg-info

%build
%py2_build
%py3_build

%install
%py2_install
%py3_install

%check
%{__python2} setup.py test
%{__python3} setup.py test

%files -n python2-%{srcname}
%license LICENSE
%doc AUTHORS
%doc PKG-INFO
%doc README.rst
%{python2_sitelib}/*

%files -n python3-%{srcname}
%license LICENSE
%doc AUTHORS
%doc PKG-INFO
%doc README.rst
%{python3_sitelib}/*

%changelog
* Mon Nov 28 2016 Jonny Heggheim <jonnyheggheim@sigaint.org> - 1.5.0-1
- inital package