Blob Blame History Raw
# Created by pyp2rpm-3.3.6
%global pypi_name mackup

%bcond_without tests

Name:           python-%{pypi_name}
Version:        0.8.32
Release:        3%{?dist}
Summary:        Keep your application settings in sync

License:        GPLv3
URL:            https://github.com/lra/mackup
# pypi_source does not have license and tests
Source0:        %{url}/archive/%{version}/%{pypi_name}-%{version}.tar.gz
BuildArch:      noarch

BuildRequires:  python3-devel
BuildRequires:  python3dist(setuptools)
%if %{with tests}
BuildRequires:  procps-ng
BuildRequires:  python3dist(pytest)
BuildRequires:  python3dist(six)
%endif

%global _description %{expand:
Mackup:
- Backs up your application settings in a safe directory (e.g. Dropbox)
- Syncs your application settings among all your workstations
- Restores your configuration on any fresh install in one command line

By only tracking pure configuration files, it keeps the cruft out of your
freshly new installed workstation (no cache, temporary and locally specific
files are transferred).

Mackup makes setting up the environment easy and simple, saving time for your
family, great ideas, and all the cool stuff you like. }

%description %{_description}


%package -n     %{pypi_name}
Summary:        %{summary}
Requires:       procps-ng

%description -n %{pypi_name} %{_description}


%prep
%autosetup -n %{pypi_name}-%{version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%py3_build

%install
%py3_install

%check
%pytest


%files -n %{pypi_name}
%license LICENSE
%doc CHANGELOG.md README.md
%{_bindir}/mackup
%{python3_sitelib}/%{pypi_name}
%{python3_sitelib}/%{pypi_name}-%{version}-py%{python3_version}.egg-info


%changelog
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.32-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 0.8.32-2
- Rebuilt for Python 3.10

* Wed May 12 2021 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.8.32-1
- Initial package