Blob Blame History Raw
%if 0%{?fedora} > 12
%global with_python3 1
%endif

%global pypi_name nose-exclude

Name:           python-%{pypi_name}
Version:        0.4.1
Release:        4%{?dist}
Summary:        Exclude specific directories from nosetests runs

License:        LGPLv2
URL:            http://pypi.python.org/pypi/nose-exclude/%{version}
Source0:        http://pypi.python.org/packages/source/n/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
BuildArch:      noarch

BuildRequires:  python2-devel
BuildRequires:  python-setuptools

Requires:       python-nose

%if 0%{?with_python3}
BuildRequires:  python3-devel
BuildRequires:  python3-setuptools
%endif

%description
nose-exclude is a `Nose`_ plugin that allows you to easily
specify directories to be excluded from testing.


%if 0%{?with_python3}
%package -n python3-%{pypi_name}
Summary:        Exclude specific directories from nosetests runs

Requires:       python3-nose

%description -n python3-%{pypi_name}
nose-exclude is a `Nose`_ plugin that allows you to easily
specify directories to be excluded from testing.
%endif


%prep
%setup -q -n %{pypi_name}-%{version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%if 0%{?with_python3}
rm -rf %{py3dir}
cp -a . %{py3dir}
%endif

%build
%{__python} setup.py build

%if 0%{?with_python3}
pushd %{py3dir}
%{__python3} setup.py build
popd
%endif

%install
%{__python} setup.py install --skip-build --root %{buildroot}

%if 0%{?with_python3}
pushd %{py3dir}
%{__python3} setup.py install --skip-build --root %{buildroot}
popd
%endif

%files
%doc README.rst
%{python_sitelib}/nose_exclude.py*
%{python_sitelib}/nose_exclude-%{version}-py?.?.egg-info

%if 0%{?with_python3}
%files -n python3-%{pypi_name}
%doc README.rst
%{python3_sitelib}/nose_exclude.py*
%{python3_sitelib}/nose_exclude-%{version}-py?.?.egg-info
%{python3_sitelib}/__pycache__/nose_exclude*
%endif

%changelog
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.1-4
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages

* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.1-2
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5

* Mon Aug 24 2015 Matthias Runge <mrunge@redhat.com> - 0.4.1-1
- update to 0.4.1 (rhbz#1256173)

* Thu Aug 20 2015 Matthias Runge <mrunge@redhat.com> - 0.4.0-1
- update to 0.4.0 (rhbz#1235283)

* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Wed May 14 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 0.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4

* Tue Feb 11 2014 Matthias Runge <mrunge@redhat.com> - 0.2.0-1
- update to 0.2.0 (rhbz#1045917)

* Tue Aug 13 2013 Matthias Runge <mrunge@redhat.com> - 0.1.10-1
- update to 0.1.10 (rhbz#993112)

* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.9-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.9-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild

* Fri Jan 18 2013 Ralph Bean <rbean@redhat.com> - 0.1.9-2
- Package python3 subpackage.

* Tue Oct 16 2012 Matthias Runge <mrunge@redhat.com> - 0.1.9-1
- update to upstream release 0.1.9

* Tue Sep 11 2012 Matthias Runge <mrunge@redhat.com> - 0.1.8-1
- Initial package.