Blob Blame History Raw

%global upname pdfrw

Name: python-pdfrw
Version: 0.1
Release: 5%{?dist}
Summary: Python library to read and write PDF files
License: MIT

Group: Development/Libraries
URL: http://code.google.com/p/pdfrw/
Source0: http://pdfrw.googlecode.com/files/%{upname}_%{version}.zip

BuildRequires: python2-devel
BuildArch: noarch

%description
pdfrw is a basic PDF file manipulation library. Developed and tested on 
Python 2.5-2.7,  pdfrw can read and write PDF files, and can also be used to 
read in PDFs which can then be used inside reportlab. 

%prep
%setup -n %{upname}_%{version} -q
sed -i -e "1d" pdfrw/pdfwriter.py 

# examples is going to docs
# I'm removing file dependencies
pushd examples
find -name "*.py" | xargs chmod -x
for i in $(grep -l -r "#\!/usr/bin/env"); do 
   sed -i -e '1d' $i; 
done
popd

%build
%{__python} setup.py build

%install
%{__python} setup.py install --skip-build --root  %{buildroot}

%files
%doc LICENSE.txt README.txt examples
%{python_sitelib}/pdfrw-*.egg-info
%{python_sitelib}/pdfrw

%changelog
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

* Tue Apr 30 2013 Sergio Pascual <sergiopr at fedoraproject.org> - 0.1-2
- Cleaned line removing buildroot in install
- Including examples in docs

* Tue Apr 30 2013 Sergio Pascual <sergiopr at fedoraproject.org> - 0.1-1
- New spec file