Blob Blame History Raw
# Latest commit
%global commit 7d2d05b805aeed0b4d3fe26d2ba97f13341ce65a
%global shortcommit %(c=%{commit}; echo ${c:0:7})
%global checkout_date  20191229

%global pypi_name tvb-data
%global module_name tvb_data

%global desc %{expand: \
The Virtual Brain Project (TVB Project) has the purpose of offering some modern
tools to the Neurosciences community, for computing, simulating and analyzing
functional and structural data of human brains.

Various demonstration datasets for use with The Virtual Brain are provided here.
}

Name:           python-%{pypi_name}
Version:        1.5.6
Release:        4.%{checkout_date}git%{shortcommit}%{?dist}
Summary:        Demo data for The Virtual Brain software

# https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
License:        GPLv3+
URL:            https://pypi.python.org/pypi/%{pypi_name}
Source0:        https://github.com/the-virtual-brain/%{pypi_name}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz

BuildArch:      noarch

%{?python_enable_dependency_generator}

%description
%{desc}

%package -n python3-%{pypi_name}
Summary:        %{summary}
BuildRequires:  python3-devel
BuildRequires:  python3-setuptools

# Not included in setup.py
Requires:       %{py3_dist numpy}
Requires:       %{py3_dist nibabel}
Requires:       %{py3_dist pillow}
Requires:       %{py3_dist scipy}
Requires:       %{py3_dist h5py}
Requires:       %{py3_dist mayavi}
Requires:       %{py3_dist networkx}

# Needs packaging but is py2 only, so we can't package it yet
# Upstream currently does not plan to migrate to py3. Trying:
# https://github.com/LTS5/cfflib/issues/7
# Leaving the cff bits in the package at the moment.
Recommends:     %{py3_dist cfflib}
# Cyclic deps. Depends on this package, so using weak deps
Recommends:     %{py3_dist tvb-library}

%{?python_provide:%python_provide python3-%{pypi_name}}

%description -n python3-%{pypi_name}
%{desc}

%prep
%autosetup -n %{pypi_name}-%{commit}
rm -rf %{pypi_name}.egg-info

%build
%py3_build

%install
%py3_install


%files -n python3-%{pypi_name}
%license LICENSE
%doc README.rst
%{python3_sitelib}/%{module_name}-%{version}-py3.?.egg-info
%{python3_sitelib}/%{module_name}

%changelog
* Sun Jan 06 2019 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 1.5.6-4.20181229git7d2d05b
- Add required requires

* Sun Jan 06 2019 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 1.5.6-3.20181229git7d2d05b
- Correct license

* Sun Jan 06 2019 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 1.5.6-2.20181229git7d2d05b
- Remove empty check
- Add setuptools BR

* Sat Dec 29 2018 Ankur Sinha <ankursinha AT fedoraproject DOT org> - 1.5.6-1.20181229git7d2d05b
- Initial build