Blob Blame History Raw
%global modname venusian

Name:           python-%{modname}
Version:        0.6
Release:        1%{?dist}
Summary:        A library for deferring decorator actions

Group:          Development/Libraries
License:        BSD
URL:            http://pypi.python.org/pypi/venusian
Source0:        http://pypi.python.org/packages/source/v/venusian/%{modname}-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch:      noarch

BuildRequires:  python-setuptools-devel
BuildRequires:  python2-devel
BuildRequires:  python-nose

%description
Venusian is a library which allows framework authors to defer decorator
actions.  Instead of taking actions when a function (or class) decorator is
executed at import time, you can defer the action usually taken by the
decorator until a separate "scan" phase.

%prep
%setup -q -n %{modname}-%{version}

%build
%{__python} setup.py build

%install
rm -rf %{buildroot}
%{__python} setup.py install -O1 --skip-build --root %{buildroot}

%check
%{__python} setup.py test

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root,-)
%doc README.txt LICENSE.txt
%{python_sitelib}/*

%changelog
* Wed Jan  2 2010 Luke Macken <lmacken@redhat.com> - 0.6-1
- Initial package