Blob Blame History Raw
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}

Name:           python-xmpp
Version:        0.3.1
Release:        1%{?dist}
Summary:        Python library for easy scripting with Jabber

Group:          Development/Languages
License:        GPL
URL:            http://xmpppy.sourceforge.net/
Source0:        http://dl.sourceforge.net/xmpppy/xmpppy-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BuildArch:      noarch
BuildRequires:  python-devel
Requires:	python-abi = %(%{__python} -c "import sys ; print sys.version[:3]")
Requires:	python-dns

%description
xmpppy is a Python library that is targeted to provide easy scripting
with Jabber. Similar projects are Twisted Words and jabber.py.

This library was not designed from scratch. It inherits some code from
jabberpy and have very similar API in many places. Though it is
separate project since it have almost completely different
architecture and primarily aims to work with jabberd2 - the new Open
Source Jabber Server.

%prep
%setup -q -n xmpppy-%{version}

# strip executable permissions so that dependencies aren't picked up
# from documentation files.
find doc -type f | xargs chmod a-x

%build
CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build

%install
rm -rf %{buildroot}
%{__python} setup.py install -O1 --skip-build --root %{buildroot}

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root,-)
%doc ChangeLog README doc/*

%dir %{python_sitelib}/xmpp
%{python_sitelib}/xmpp/*.py
%{python_sitelib}/xmpp/*.pyc
%ghost %{python_sitelib}/xmpp/*.pyo

%changelog
* Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.3.1-1
- First version for Fedora Extras