Blob Blame History Raw
# Generated by rust2rpm 22
# * ntest crates are not packaged yet
%bcond_with check
%global debug_package %{nil}

%global crate async-compression

Name:           rust-async-compression
Version:        0.3.15
Release:        %autorelease
Summary:        Adaptors between compression crates and Rust's modern asynchronous IO types

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/async-compression
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * drop tokio 0.3 support (Fedora only ships tokio 0.1, 0.2, and 1.0)
Patch:          async-compression-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Adaptors between compression crates and Rust's modern asynchronous IO types.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+all-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+all-devel %{_description}

This package contains library source intended for building other packages which
use the "all" feature of the "%{crate}" crate.

%files       -n %{name}+all-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+all-algorithms-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+all-algorithms-devel %{_description}

This package contains library source intended for building other packages which
use the "all-algorithms" feature of the "%{crate}" crate.

%files       -n %{name}+all-algorithms-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+all-implementations-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+all-implementations-devel %{_description}

This package contains library source intended for building other packages which
use the "all-implementations" feature of the "%{crate}" crate.

%files       -n %{name}+all-implementations-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+brotli-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+brotli-devel %{_description}

This package contains library source intended for building other packages which
use the "brotli" feature of the "%{crate}" crate.

%files       -n %{name}+brotli-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+bytes-05-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+bytes-05-devel %{_description}

This package contains library source intended for building other packages which
use the "bytes-05" feature of the "%{crate}" crate.

%files       -n %{name}+bytes-05-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+bzip2-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+bzip2-devel %{_description}

This package contains library source intended for building other packages which
use the "bzip2" feature of the "%{crate}" crate.

%files       -n %{name}+bzip2-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+deflate-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+deflate-devel %{_description}

This package contains library source intended for building other packages which
use the "deflate" feature of the "%{crate}" crate.

%files       -n %{name}+deflate-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+flate2-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+flate2-devel %{_description}

This package contains library source intended for building other packages which
use the "flate2" feature of the "%{crate}" crate.

%files       -n %{name}+flate2-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+futures-bufread-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+futures-bufread-devel %{_description}

This package contains library source intended for building other packages which
use the "futures-bufread" feature of the "%{crate}" crate.

%files       -n %{name}+futures-bufread-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+futures-io-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+futures-io-devel %{_description}

This package contains library source intended for building other packages which
use the "futures-io" feature of the "%{crate}" crate.

%files       -n %{name}+futures-io-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+futures-write-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+futures-write-devel %{_description}

This package contains library source intended for building other packages which
use the "futures-write" feature of the "%{crate}" crate.

%files       -n %{name}+futures-write-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gzip-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gzip-devel %{_description}

This package contains library source intended for building other packages which
use the "gzip" feature of the "%{crate}" crate.

%files       -n %{name}+gzip-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+libzstd-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+libzstd-devel %{_description}

This package contains library source intended for building other packages which
use the "libzstd" feature of the "%{crate}" crate.

%files       -n %{name}+libzstd-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+lzma-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+lzma-devel %{_description}

This package contains library source intended for building other packages which
use the "lzma" feature of the "%{crate}" crate.

%files       -n %{name}+lzma-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+stream-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+stream-devel %{_description}

This package contains library source intended for building other packages which
use the "stream" feature of the "%{crate}" crate.

%files       -n %{name}+stream-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+tokio-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-devel %{_description}

This package contains library source intended for building other packages which
use the "tokio" feature of the "%{crate}" crate.

%files       -n %{name}+tokio-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+tokio-02-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-02-devel %{_description}

This package contains library source intended for building other packages which
use the "tokio-02" feature of the "%{crate}" crate.

%files       -n %{name}+tokio-02-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xz-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xz-devel %{_description}

This package contains library source intended for building other packages which
use the "xz" feature of the "%{crate}" crate.

%files       -n %{name}+xz-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+xz2-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+xz2-devel %{_description}

This package contains library source intended for building other packages which
use the "xz2" feature of the "%{crate}" crate.

%files       -n %{name}+xz2-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+zlib-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+zlib-devel %{_description}

This package contains library source intended for building other packages which
use the "zlib" feature of the "%{crate}" crate.

%files       -n %{name}+zlib-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+zstd-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+zstd-devel %{_description}

This package contains library source intended for building other packages which
use the "zstd" feature of the "%{crate}" crate.

%files       -n %{name}+zstd-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+zstd-safe-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+zstd-safe-devel %{_description}

This package contains library source intended for building other packages which
use the "zstd-safe" feature of the "%{crate}" crate.

%files       -n %{name}+zstd-safe-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires -a

%build
%cargo_build -a

%install
%cargo_install -a

%if %{with check}
%check
%cargo_test -a
%endif

%changelog
%autochangelog