Blob Blame History Raw
# Generated by rust2rpm
%bcond_with check
%global debug_package %{nil}

%global crate cssparser

Name:           rust-%{crate}
Version:        0.25.5
Release:        1%{?dist}
Summary:        Rust implementation of CSS Syntax Level 3

# Upstream license specification: MPL-2.0
License:        MPLv2.0
URL:            https://crates.io/crates/cssparser
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(cssparser-macros/default) >= 0.3.3 with crate(cssparser-macros/default) < 0.4.0)
BuildRequires:  (crate(dtoa-short/default) >= 0.3.0 with crate(dtoa-short/default) < 0.4.0)
BuildRequires:  (crate(itoa/default) >= 0.4.0 with crate(itoa/default) < 0.5.0)
BuildRequires:  (crate(matches/default) >= 0.1.0 with crate(matches/default) < 0.2.0)
BuildRequires:  (crate(phf/default) >= 0.7.0 with crate(phf/default) < 0.8.0)
BuildRequires:  (crate(proc-macro2/default) >= 0.4.0 with crate(proc-macro2/default) < 0.5.0)
BuildRequires:  (crate(procedural-masquerade/default) >= 0.1.0 with crate(procedural-masquerade/default) < 0.2.0)
BuildRequires:  (crate(quote/default) >= 0.6.0 with crate(quote/default) < 0.7.0)
BuildRequires:  (crate(smallvec/default) >= 0.6.0 with crate(smallvec/default) < 0.7.0)
BuildRequires:  (crate(syn/default) >= 0.15.12 with crate(syn/default) < 0.16.0)
BuildRequires:  (crate(syn/extra-traits) >= 0.15.12 with crate(syn/extra-traits) < 0.16.0)
BuildRequires:  (crate(syn/fold) >= 0.15.12 with crate(syn/fold) < 0.16.0)
BuildRequires:  (crate(syn/full) >= 0.15.12 with crate(syn/full) < 0.16.0)
%if %{with check}
BuildRequires:  (crate(difference/default) >= 2.0.0 with crate(difference/default) < 3.0.0)
BuildRequires:  (crate(encoding_rs/default) >= 0.8.0 with crate(encoding_rs/default) < 0.9.0)
BuildRequires:  (crate(rustc-serialize/default) >= 0.3.0 with crate(rustc-serialize/default) < 0.4.0)
%endif

%global _description \
Rust implementation of CSS Syntax Level 3.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/docs

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+bench-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+bench-devel %{_description}

This package contains library source intended for building other packages
which use "bench" feature of "%{crate}" crate.

%files       -n %{name}+bench-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+dummy_match_byte-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dummy_match_byte-devel %{_description}

This package contains library source intended for building other packages
which use "dummy_match_byte" feature of "%{crate}" crate.

%files       -n %{name}+dummy_match_byte-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+heapsize-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+heapsize-devel %{_description}

This package contains library source intended for building other packages
which use "heapsize" feature of "%{crate}" crate.

%files       -n %{name}+heapsize-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-devel %{_description}

This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.

%files       -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
# https://github.com/servo/rust-cssparser/issues/213
%cargo_test -- --doc
%endif

%changelog
* Tue Apr 30 09:40:06 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.25.5-1
- Update to 0.25.5

* Wed Apr 03 2019 Josh Stone <jistone@redhat.com> - 0.25.3-1
- Update to 0.25.3

* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.25.2-1
- Update to 0.25.2

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Thu Oct 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.24.1-1
- Update to 0.24.1

* Sun Jul 29 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.24.0-3
- Bump encoding_rs to 0.8

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Sat Jun 30 2018 Josh Stone <jistone@redhat.com> - 0.24.0-1
- Update to 0.24.0

* Sat Jun 23 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org>
- Adopt to new macro

* Thu Jun 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.23.10-1
- Update to 0.23.10

* Tue Jun 05 2018 Josh Stone <jistone@redhat.com> - 0.23.9-1
- Update to 0.23.9

* Thu May 03 2018 Josh Stone <jistone@redhat.com> - 0.23.7-1
- Update to 0.23.7

* Sat Apr 28 2018 Josh Stone <jistone@redhat.com> - 0.23.6-1
- Update to 0.23.6

* Tue Apr 17 2018 Josh Stone <jistone@redhat.com> - 0.23.5-1
- Update to 0.23.5

* Wed Apr 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.23.4-1
- Update to 0.23.4

* Mon Mar 26 2018 Josh Stone <jistone@redhat.com> - 0.23.2-4
- Bump itoa to 0.4.0

* Fri Mar 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.23.2-3
- Bump syn to 0.12, quote to 0.4

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.23.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Wed Jan 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.23.2-1
- Initial package