Blob Blame History Raw
# Generated by rust2rpm 13
# * Tests are too environment dependent
%bcond_with check
%global debug_package %{nil}

%global crate curl

Name:           rust-%{crate}
Version:        0.4.31
Release:        2%{?dist}
Summary:        Rust bindings to libcurl for making HTTP requests

# Upstream license specification: MIT
License:        MIT
URL:            https://crates.io/crates/curl
Source:         %{crates_source}
# Initial patched metadata
# * No windows/osx
Patch0:         curl-fix-metadata.diff

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Rust bindings to libcurl for making HTTP requests.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+force-system-lib-on-osx-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+force-system-lib-on-osx-devel %{_description}

This package contains library source intended for building other packages
which use "force-system-lib-on-osx" feature of "%{crate}" crate.

%files       -n %{name}+force-system-lib-on-osx-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+http2-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+http2-devel %{_description}

This package contains library source intended for building other packages
which use "http2" feature of "%{crate}" crate.

%files       -n %{name}+http2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+mesalink-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+mesalink-devel %{_description}

This package contains library source intended for building other packages
which use "mesalink" feature of "%{crate}" crate.

%files       -n %{name}+mesalink-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+openssl-probe-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+openssl-probe-devel %{_description}

This package contains library source intended for building other packages
which use "openssl-probe" feature of "%{crate}" crate.

%files       -n %{name}+openssl-probe-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+openssl-sys-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+openssl-sys-devel %{_description}

This package contains library source intended for building other packages
which use "openssl-sys" feature of "%{crate}" crate.

%files       -n %{name}+openssl-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+protocol-ftp-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+protocol-ftp-devel %{_description}

This package contains library source intended for building other packages
which use "protocol-ftp" feature of "%{crate}" crate.

%files       -n %{name}+protocol-ftp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+spnego-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+spnego-devel %{_description}

This package contains library source intended for building other packages
which use "spnego" feature of "%{crate}" crate.

%files       -n %{name}+spnego-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+ssl-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ssl-devel %{_description}

This package contains library source intended for building other packages
which use "ssl" feature of "%{crate}" crate.

%files       -n %{name}+ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+static-curl-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+static-curl-devel %{_description}

This package contains library source intended for building other packages
which use "static-curl" feature of "%{crate}" crate.

%files       -n %{name}+static-curl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+static-ssl-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+static-ssl-devel %{_description}

This package contains library source intended for building other packages
which use "static-ssl" feature of "%{crate}" crate.

%files       -n %{name}+static-ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.31-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Thu Jul 23 2020 Josh Stone <jistone@redhat.com> - 0.4.31-1
- Update to 0.4.31

* Fri Jun 26 2020 Josh Stone <jistone@redhat.com> - 0.4.30-1
- Update to 0.4.30

* Sun May 17 16:11:49 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.4.29-2
- Restore static features

* Wed Apr 29 2020 Josh Stone <jistone@redhat.com> - 0.4.29-1
- Update to 0.4.29

* Fri Mar 13 2020 Josh Stone <jistone@redhat.com> - 0.4.28-1
- Update to 0.4.28

* Tue Mar 10 2020 Josh Stone <jistone@redhat.com> - 0.4.27-1
- Update to 0.4.27

* Mon Mar 02 2020 Josh Stone <jistone@redhat.com> - 0.4.26-1
- Update to 0.4.26

* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.25-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Sat Nov 23 2019 Josh Stone <jistone@redhat.com> - 0.4.25-1
- Update to 0.4.25

* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.22-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Mon Jun 03 2019 Josh Stone <jistone@redhat.com> - 0.4.22-1
- Update to 0.4.22

* Thu Mar 14 2019 Josh Stone <jistone@redhat.com> - 0.4.20-1
- Update to 0.4.20

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.19-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Sat Nov 10 2018 Josh Stone <jistone@redhat.com> - 0.4.19-1
- Update to 0.4.19
- Adapt to new packaging

* Mon Oct 01 2018 Josh Stone <jistone@redhat.com> - 0.4.18-1
- Update to 0.4.18

* Mon Sep 17 2018 Josh Stone <jistone@redhat.com> - 0.4.17-1
- Update to 0.4.17

* Thu Sep 13 2018 Josh Stone <jistone@redhat.com> - 0.4.15-1
- Update to 0.4.15

* Fri Sep 07 2018 Josh Stone <jistone@redhat.com> - 0.4.14-1
- Update to 0.4.14

* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.12-2
- Rebuild to trigger tests

* Sun Jul 22 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.12-1
- Update to 0.4.12

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.11-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Sat Jan 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.11-1
- Initial package