Blob Blame History Raw
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}

%global crate event-listener

Name:           rust-event-listener
Version:        5.3.0
Release:        %autorelease
Summary:        Notify async tasks or threads

License:        Apache-2.0 OR MIT
URL:            https://crates.io/crates/event-listener
Source:         %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch:          event-listener-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
# * drop feature for unsupported loom permutation testing framework
Patch:          event-listener-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Notify async tasks or threads.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+parking-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+parking-devel %{_description}

This package contains library source intended for building other packages which
use the "parking" feature of the "%{crate}" crate.

%files       -n %{name}+parking-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+portable-atomic-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+portable-atomic-devel %{_description}

This package contains library source intended for building other packages which
use the "portable-atomic" feature of the "%{crate}" crate.

%files       -n %{name}+portable-atomic-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+portable-atomic-util-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+portable-atomic-util-devel %{_description}

This package contains library source intended for building other packages which
use the "portable-atomic-util" feature of the "%{crate}" crate.

%files       -n %{name}+portable-atomic-util-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+portable_atomic_crate-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+portable_atomic_crate-devel %{_description}

This package contains library source intended for building other packages which
use the "portable_atomic_crate" feature of the "%{crate}" crate.

%files       -n %{name}+portable_atomic_crate-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog