Blob Blame History Raw
# Generated by rust2rpm 17
%bcond_without check
%global debug_package %{nil}

%global crate file-per-thread-logger

Name:           rust-%{crate}
Version:        0.1.4
Release:        2%{?dist}
Summary:        Logging implementation that writes logs in one file per thread

# Upstream license specification: Apache-2.0 WITH LLVM-exception
License:        ASL 2.0 with exceptions
URL:            https://crates.io/crates/file-per-thread-logger
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Logging implementation that writes logs in one file per thread.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%doc README.md
%license LICENSE
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
# Tests have to run one after the other because cargo test uses multiple threads
# Cf. https://github.com/bnjbvr/file-per-thread-logger/blob/1fb9c9e14/.github/workflows/rust.yml#L25
%cargo_test tests
%cargo_test formatted_logs
%cargo_test uninitialized_threads_should_panic
%cargo_test logging_from_uninitialized_threads_allowed
%endif

%changelog
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Sun May 23 16:29:33 CEST 2021 Olivier Lemasle <o.lemasle@gmail.com> - 0.1.4-1
- Initial package