Blob Blame History Raw
# Generated by rust2rpm
# * Tests do not work out of the tree
#   https://github.com/rust-lang-nursery/futures-rs/issues/1019
%bcond_with check
%global debug_package %{nil}

%global crate futures-util
%global real_crate futures-util-preview

Name:           rust-%{crate}
Version:        0.2.2
Release:        1%{?dist}
Summary:        Common utilities and extension traits for the futures-rs library

# Upstream license specification: MIT/Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/futures-util-preview
Source0:        https://crates.io/api/v1/crates/%{real_crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove -preview suffix
Patch0:         futures-util-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
# [dependencies]
BuildRequires:  (crate(either) >= 1.4.0 with crate(either) < 2.0.0)
BuildRequires:  (crate(futures-channel) >= 0.2.2 with crate(futures-channel) < 0.3.0)
BuildRequires:  (crate(futures-core) >= 0.2.2 with crate(futures-core) < 0.3.0)
BuildRequires:  (crate(futures-io) >= 0.2.2 with crate(futures-io) < 0.3.0)
BuildRequires:  (crate(futures-sink) >= 0.2.2 with crate(futures-sink) < 0.3.0)

%description
%{summary}.

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel
Common utilities and extension traits for the futures-rs library.

This package contains library source intended for building other packages
which use %{crate} from crates.io.

%prep
%autosetup -n %{real_crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%{cargo_registry}/%{crate}-%{version}/

%changelog
* Tue Sep 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.2-1
- Update to 0.2.2

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Mon May 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
- Initial package