Blob Blame History Raw
# Generated by rust2rpm
%bcond_without check
%global debug_package %{nil}

%global crate fuzzy-matcher

Name:           rust-%{crate}
Version:        0.2.1
Release:        1%{?dist}
Summary:        Fuzzy Matching Library

License:        MIT
URL:            https://crates.io/crates/fuzzy-matcher
Source:         %{crates_source}
# https://github.com/lotabout/fuzzy-matcher/pull/3
Patch0:         0001-Fix-import-in-tests.patch

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
%if %{with check}
BuildRequires:  (crate(termion/default) >= 1.5.1 with crate(termion/default) < 2.0.0)
%endif

%global _description \
Fuzzy matching algorithms in Rust.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%doc README.md examples
%license LICENSE
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sun Apr 14 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.1-1
- Initial package